UPnP in V1.4

Hi, I have a simple question and problem.
I am using the AirAudio app on my Android device and I can select Volumio as the reciever and play through AirPlay, but when I switch to DLNA/UPnP I get no sound at all. Volumio is present in the app both as a AirPlay and DLNA receiver.
I have both AirPlay and DLNA selected as services in the settings of Volumio.

I have tried the BubbleUPnP app aswell but with the same result.

What can I do to get the DLNA renderer to work?

I can play local files on my device using BubbleUPnP.
So this indicates that the DLNA renderer in my Pi/Volumio works. Good!

This also means that the issue is with the AirAudio app and not with the Pi/Volumio.

Another update!

Tested my Android device and the AirAudio app with another DLNA/UPnP capable renderer (an Onkyo TX-NR414 Receiver) and then it works!
So I am back to that there may be something in the Pi/Volumio set-up that is not as it should.

Anyone with ideas on what could be done?

BTW The BubbleUPnP app also worked with the Onkyo receiver.

I had UPNP working properly on 1.2 with the instructions of coraline in the post “UPNP renderer on Volumio” (gmediarender). I used this with foobar (foo_upnp), bubble UPNP on android and synology’s audio station/DS audio succesfully.

Today i tried the 1.4 version and got a bit disappointed the UPNP doesn’t seem to work all the time. It works for me in Bubble UPNP, however the UPNP renderer doesn’s show up in DS audio/audio station. It shows up in foobar, but only generates a lot of noise…

I had also some issues with the (sh)airplay option, but was finaly able to fix this (see post “Airplay name won’t change from volumio”)

Update: using BubbleUPNP only mp3 files are properly working, Flac files only seem to generate a lot of noise.

Thanks for your feedback Marcos.

I have done some further investigations involving two different aDevices (Android devices) and two different apps on these and this is what I have found out

  1. AirAudio app cannot play system-audio through DLNA on both device, generates some noise though!
  2. AirAudio app can play system-audio through AirPlay on both devices!
  3. BubblePUPnP app can play local media (media on the device) through DLNA on either device
  4. BubblePUPnP app cannot play system-audio (AirCast) through DLNA on either device, generates some noise though! (same as on 1.)

This lead me to think

  1. It is not aDevice related, same issue on two different devices.
  2. There is a difference in how local media is treated and how system-audio is treated,

I also tried to connect to my Onkyo TX-NR414 (with DNLA) and both apps could connect and play system-audio!!!

So now we are homing in on the Volumio/RPi as the culprit!

A further investigation on transportformats with help from AirAudio people led me to

  1. LPCM can connect to RPi, but not play. (case 1. and 4. above)
  2. WAV cannot connect to RPi
  3. MP3 can connect to RPi and play!!! but with a lot of dropouts

Anyone that can make any suggestions based on this?

I found this alternative DLNA renderer
Is it worth trying this out instead of the one in 1.4?

My earlier reported problems with BubbleUpnp and flac-files and your recent posting got me busy. Seems that BubbleUpnp is able to play local flac (16 and 24 bits) properly on Volumio. This leads me to the synology settings in mediaserver (DSM 5.0). There is a setting in mediaserver which forces transcoding (“enable audio transcoding”). I had this enabled in order to play files on my old mediaplayer. I disabled it and no longer the upmpdcli/MPD software on Volumio seems to have a problem playing flac files! :stuck_out_tongue:

Looks like upmpcli/MPD isn’t able to play transcoded files properly but only accepts the original format. This might be the problem with your UPNP server.

The other issue left is that synology’s audiostation isn’t able to see Volumio as an upnp device (to know if you facing airplay or UPNP you have to change the name, see my other post). I restarted my NAS and there it was: audiostation shows both VolumioUpnp and VolumioAir!

Next problem: MPD library showed up empty. Restarting Volumio makes VolumioUpnp disappear in audiostation. Only a stop and start of mediaserver was enough to get it back. But this empties the library again… An update MPD database fixed this. So next time: restart Volumio > restart mediaserver > update MPD :imp:

Also fixed foobar/foo_upnp by making a profile for Volumio in “streaming profile” settings and setting decoding to PCM to Never (use profile when User-Agent contains upmpd seemed to work).

I just want to know if someone achieve to make work a stream from Ubuntu 14.04 to Volumio ?
from Ubuntu :
i configure properly pulseaudio
With airplay I see Volumio, but if I select it it hangs the player.
If I try upnp, player plays, but no sound.
From Android using Allstream:
Airplay ok
Upnp does not work
Any experience ?