Upgrade to 2.114 killed my Volumio2

I really love this project, but upgrading from the previous 2.x version to the current 2.114 killed my Volumio2 installation, which worked for nearly 1/2 year with all upgrades.

  • I can’t connect anymore with ssh to the Raspberry. Running sshd in debug mode (after connecting a monitor and keyboard) I see this error: mm_log_handler: write: broken pipe

  • ping somehost.fqdn results in an segmentation fault error. But the command host somehost.fqdn is working and results in the corresponding IP address

  • After the upgrade SMB mount is also failing, so I can’t mount anymore my MP3 files from my NAS

This are only some issue I found after the upgrade.

Before I try to flash the SD card with a new Volumio2 image I would like to know, why this could happen?


ok, I’ve tested a little bit with my Volumio2 box:

  1. sshd is only working from the Volumio2 installation to itself with ssh localhost. If I try it from the Volumio2 box to its WLAN IP I get the same error. I tried it also with a ethernet connection instead WLAN, with the same result. ssh out from the Volumio2 box to other hosts is working
  2. ping only works with IP addresses, not with hostnames
  3. SMB mount is working again after I have added the domain to the NAS name, I have to use the FQDN. I didn’t had this before and the Domain is included in the /etc/resolv.conf


I originally updated a RPi3 to 2.114 through the UI, and found problems with not being able to authenticate over ssh. I reflashed with the official release downloaded from the Volumio website, and everything appears to be fine. No idea what the problem is, but at least there is a working solution.

Indeed there have been several networking related updates with this release, some impacting both Volumio2 app per say, some in the root config files in the Build project.
It may indeed probably better to reflash a new up-to-date image to get advantage of the benefits, and avoid potential quirks of eventually non-matching stuff.

SSH and SFTP problems here after the upgrade to Vol.2.114 The player it self works ok, but i cannot access it anymore wth SSH (putty) or SFTP (WinScp)
The previous release (12 dec16) worked ok. There seems to be a problem with authentication or the secure key.

I use RaspbPi B2.

gr. Jan

Thanks for the update. Unfortunately this seems also the best working solution for me, even I hoped to get another solution. Maybe it would be a good idea, to implement a export and import function of some settings (e.g. WLAN key or SMB shares)? So reflashing and the new setup would be a little bit faster.


Already, raised on github https://github.com/volumio/Volumio2/issues/1048

Great! I am waiting forward to see this feature.

i solved same issue.
modified /etc/ssh/sshd_config file.
change usepam yes->no(maybe last lime
and restart ssh(/etc/init.d/ssh restart)

jantle’s solution works!