Unable to manage the sound via the interface

Since the update to, I can no longer manage the sound of volumio.
Why ?

Thank you for your answers

Can you be more specific. Volume? Or sound settings? And if so what? And what sound ouput device do you use, etc.

I use a card dac hifiberry DAC +.
In the playback option, there is in output device: HIFIBerry DAC + HIFI pcm512X-hifi-0.
This is connected to my home theater amplifier
I order from my PC by the url on my local network.
Normally I can play on the sound but it does not matter.

Here is

I think I need to modify a configuration file so that my HIFIBerry card is manageable.
I try through the output jack and there I can go up and down the volume.

How to do ?

thank you

Now I no longer sound as if I were losing the peripherals.

By dint of reading, hacking, I restored the sound.
But I still have the problem with the interface, it seems that it works partially.
For example, the fast forward, stop and run buttons work, but not the volume button.
I use the latest version of volumio, is there not a problem with?

In attachment my configuration seems correct

Thank you for your answers
Capture volumio.PNG

Enable i2s DAC. In the list below select your dac and save.
To control the volume, a hardware mixer should be selected.


This does not solve the problem, the sound is 100 and I can not fix it.
Even without active i2s, it worked and I could increase or lower the sound. Now no matter what the setting.

Thank you for your answers
Capture volumio2.PNG

Not finding the solution, I had given up but it gets me a bit of not being able to enjoy my music.

I always have the problem, impossible to vary the sound, why?

Thank you for your answers.

Did you make this settings?

In Playback Options choose
Mixer Type: Hardware
Mixer Control Name: Digital

Did you set


in /boot/config.txt

I have :

Commed the line “dtparam = audio = on” in the config file
Always added to this file dtoverlay = hifiberry-dacplus.
Created the file asound.conf with conf:

pcm.! default {
type hw card 0
ctl.! default {
type hw card 0

I just switched to digital as a precondition and I no longer have sound.

Here is

You need to

  • Do a factory reset
  • Enable i2s and select hifiberry

that’s it

I also use the DAC+.
I did not have to edit anything in /etc/asound.conf. I’ve left the file as it is.
I doubt that your DAC+ is “card 0”. The DAC+ should be “card 1”.

volumio@VolumioWZ:~$ aplay -l **** List of PLAYBACK Hardware Devices **** card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA] Subdevices: 8/8 Subdevice #0: subdevice #0 Subdevice #1: subdevice #1 Subdevice #2: subdevice #2 Subdevice #3: subdevice #3 Subdevice #4: subdevice #4 Subdevice #5: subdevice #5 Subdevice #6: subdevice #6 Subdevice #7: subdevice #7 card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI] Subdevices: 1/1 Subdevice #0: subdevice #0 card 1: sndrpihifiberry [snd_rpi_hifiberry_dacplus], device 0: HiFiBerry DAC+ HiFi pcm512x-hifi-0 [] Subdevices: 1/1 Subdevice #0: subdevice #0
My suggestion would be make a backup of your asound.conf and then delete your entries in asound.conf, reboot.

I will try but to see I am passing on the competition although it is in English but not yet the ideal I can adjust the sound


I just reinstaller volumio.

I have the interface in French
The increment of the sound by 5
Select hifiberry DAC

I therefore did not intervene in the file config.txt
I did not create the files asound.conf

Well I still can not adjust the sound.
Everything is by default and unfortunately it does not work.
If you have ideas, because I dry.

Thank you for your answers.

I have just realized that the sound increases when I put myself at 95 for example and that I go up to 100.
Below 95 it is inoperative.
The “mute” function does not work either.