UDOO Quad - Airplay (shairport) - USB DAC

Hi. Great project!
Just installed Volumio on my UDOO Quad.
So far I’ve encountered some problems regarding airplay:

  1. In UDOO Quad the audio output automatically changes to the built-in jack of the UDOO when activating Shairport, completely ignoring my USB DAC (Behringer UCA202). So far I haven’t been able to change the output to the USB DAC on Shairport mode.

  2. It’d be awesome if we could activate shairport from within the webUI, rather than using

/etc/init.d/shairport start

from SSH. I think it would really improve the overall experience.

  1. Shairport is OFF by default.

Really looking forward for this features in future releases, and if someone has any idea on how to implement a quick workaround for this (specially the USB DAC thing), it would be greatly appreciated.

Again, congrats on this great project.

Ok, finally managed to get airplay working on my USB DAC and UDOO Quad (sounds great!! :smiley: ).
For anyone having the same problem here is one solution:

I had to first run:

aplay -l to see a list of available sound output devices, in which my usb was the last one, showing something like this:

card 2: USB Device, device 0: USB CODEC

Then, it is very important to stop MPD so that both, the USB DAC and Volumio itself won’t conflict:

mpc stop

Finally, you need to configure Shairport output using the information aplay -l gave you. In my case, the card has “2” assigned, and “0” for the device (not really sure what that means :blush: ).

shairport -o alsa -- -d hw:2,0

Notice how I used “2” and “0” consecutively in the “hw” part, based on the info “aplay -l” gave me.

This is far from an ideal solution mainly because I think it is somehow bypassing Volumio at some point. The name Volumio shows up in iDevices as airplay enabled changes from “volumio” to “Shairport on volumio”.

Other issue regarding this solution is that the command line blocks any further user input, constantly showing messages like this: “WARNING: requesting resend on 12 packets (A5BD:A5C8)” constantly.

When running shairport like this: /etc/init.d/shairport start the same messages show up, but user input is still possible.

Michelangelo, any ideas?


After several hours fiddling with the Volumio source I think i got everything running. If everything goes well, tomorrow (Mexico City time) I may be able to add an “activate Airplay” button to the webUI.

I will also post a thorough tutorial so that anyone can add an “activate airplay” button to their volumio webUI.

Maybe I should move this thread to a more appropriate section of the forum…

UPDATE: done! http://volumio.org/forum/web-enhancements-t1236.html#p4715