Topping E30 DSD Direct

Hi,

I have a brand new installation of Volumio with a Topping E30 DAC and I’m just now trying to play some dsd files. They play, but the Topping display says PCM. I’ve tried to mess with the settings but no mater what I do it seems Volumio is converting to PCM? I have the e30 in DAC mode. I turned off the “hardware” mixer in Volumio, setting it to none. It didn’t change it.

Any ideas for me? These are definitely .dsf files created from SACD disks. They play as DSD on my AVR.

1 Like

I just found the thread reporting this problem from last year. Sorry for the double post.
Is there any ETA on a fix?

E30 plays DSD direct fine here, connected to RPi4.

1 Like

What version are you using?
Thanks

latest - v2.873

Ok, because I am on rpi beta version 3.054 and in order to listed to dsd files I need to select dsd over dop. The settings are inversed. Maybe one colleagues from @volumio team will check this and give a feedback.

I’m using the latest 2.873

It was a fresh installation from a few days ago.
The e30 is also brand new.

Yes, that is it! The setting is wrong/inverted in the UI!
Now I’m playing DSD!
I guess I tried everything but that. :wink:

1 Like

I am happy to hear that, is curios that no one from volumio says anything about this bug :frowning:

2 Likes

Curious - haven’t found any equivalent bug here - DSD worked fine from fresh install with standard settings (here for avoidance of doubt):

RPi 4 > Topping E30 - Volumio v2.873
DSD Playback Mode: DSD Direct
DSD Auto Volume Level: Off
Volume Normalization: Off
Audio Buffer Size: 2 MB
Buffer Before Play: 10%
Persistent Queue: On
Playback Mode: Continuous

Mixer Type: Hardware
Mixer Control Name: E30
Default Startup Volume: Disabled
Max Volume Level: 100
One Click Volume Steps: 10
Volume Curve Mode: Natural
MPD Clients Volume Control: Off

Hello,

@volumio would you please be kind to tell us the configuration for playing dsd files.
As we can see we have different config for making working. Also please give a feedback regarding inverse settings for dsd direct option.
Mnay thanks

Just tested the latest beta and DSD behaves just fine.
IMHO, if to get DSD you have to set it to DoP, it’s not because settings are inverrted but because your DAC does not support directDSD or its quirks are not into the kernel yet

Understood, but if I set dop on volumio, on my dac topping e30 I see dsd 5.64 MHz.
If I set dsd direct I see pcm…

Thanks for explanation.

That confirms my idea:
Volumio does not recognize your DAC as capable of receiving direct DSD stream, so it converts to PCM if DSD Direct is set

Ok. So if I set direct dsd then volumio think that automatically topping e30 supports dsd but it does not
But if I set to dop then e30 will see the dsd stream?
At first step volumio makes something to stream? Some checks
This is do not understand

Do you see on the dac the dsd? Not pcm with above settings because I have other behavior on buster beta 3.063

1 Like

Of course. E30 in DAC mode. DSD displayed.
All very mysterious. Maybe you have an earlier firmware? Batches up to 2003 need updating afaik.

The SN is : 2006731727. Do I need to udpate it ?

thanks

Nope that should be fine. The other obvious difference is that you’re on Volumio v3 Beta? I’m using v2 fwiw.

I will do some further tests.
Maybe it is an issue with buster beta but volumio team conformed that behavior is ok…