Timezone Setting & Daylight Saving Time

A small issue I’ve noticed that with the clocks changing recently Volunio has not updated to British Summer Time (I imagine this in not uk specific) and despite several reboots and full restarts does not automatically update.
I saw elsewhere a thread about the background check for time happens before the WiFi is up so volumio misses syncing with the time server. Or perhaps local isn’t set right ie it’s universal rather than local. It was quite an old thread and I can’t put my hand o it right now- anyway the bug seems to persist/exist.

This is something I had to do on every fresh install of Volumio (2.x):

  • ensure that CRDA is set with the proper county code (REGDOMAIN=xx) in /etc/default/crda, followed by the commands:
  • timedatectl set-ntp true
  • sudo dpkg-reconfigure tzdata

As far as I know, Volumio uses UTC. UTC and BST are the same when not in DST (winter) and UTC doesn’t do DST. Rebooting doesn’t help, it’s an other time area/zone/code.
What @dheijl does is a solution for the time zone but I don’t really know why you would need to do it.

For the CRDA, this might be a good thing to add for the Wi-Fi Hotspot. But I believe it doesn’t really matter when your just a client

In my case, I built a speaker for the kitchen and I want it to be on in the morning when I go down to make a hot drink. Having to reset the alarm after the clocks changes is a pain. Perhaps a GUI element under the alarm tab that enables location / time zone to be set would be a good inclusion.

Timezone setting periodically comes up. I guess it’s a matter of priorities. Best place for it, I think, would be the ‘First run’ wizard.

sudo dpkg-reconfigure tzdata

allows you to pick Europe/London from a menu, or you can just issure the command:

sudo timedatectl  set-timezone Europe/London

And a sudden increase in chatter about twice a year around March/April, and then again in October/November? :wink:

Thank you for the information.