Tidal Connect stops

Volumio 3.198 on Raspberry Pi 4

Tidal Connect frequently stops playing. It will play part of a song, or sometimes a few songs and then stop. The pause button spins. Sometimes you can skip tracks and it will resume. Sometimes not.

I see other people mentioning the same issue. I did not use Tidal Connect on v2.x so I don’t know if this is a v3 issue.

2 Likes

Yes this is a V3 issue which we are currently investigating.
We have a really strong hypothesis of why that happens and we are working on a fix.

One question which might help us: which ISP do you have? Which country are you in?
Thanks

1 Like

ISP is AT&T Fiber
In the U.S.A.

Thanks man. By any chance, do you know if this ISP uses some sort of NAT?

same here with cox cable internet in the usa.

I’m not behind CGNAT

Same proglem here, setup as followed:

ISP : Fizz (in Canada, no idea if they use a NAT),
Raspberry Pi 3B+
Allo Digione Signature HAT
COAX output used.

Thanks for looking into it!

Same issue on Spectrum internet. Pi4.

For people who dont know if they are behand a CGNAT:
got to https://www.whatismyip.com/ and copy your public IP
Enter your puplic ip at the end op this url:Webupdates — RIPE Network Coordination Centre
If your ISP uses a CGNAT, you see something like this:

As answer to the question, tested with 4 Albums (36 tracks)
ISP: Ziggo (Netherlands)
CGNAT: No
RpI4-8GB, Rev:1.4
DAC: NAD D3045 (USB)
Volumio: V3.209
No problems with Tidal connect from iOS.

Thanks for the tip!

However, my attempt led to this result:

netname: NON-RIPE-NCC-MANAGED-ADDRESS-BLOCK
descr: IPv4 address block not managed by the RIPE NCC

Not sure if I did something wrong… Or if it means that I don’t have a CGNAT?

No, Most likely your ISP blocks the WebCrawler from RIPE. nothing to worry about.

This means the netblock is not assigned by RIPE:
netname: NON-RIPE-NCC-MANAGED-ADDRESS-BLOCK
descr: IPv4 address block not managed by the RIPE NCC

RIPE allocates European IP addresses. If your ISP is in the US it’s likely allocated by ARIN.

Use this instead for ARIN and put your IP at the end of the URL

ARIN Whois/RDAP - American Registry for Internet Numbers

1 Like

I also got an unhelpful result @Wheaten


netname:         BT-CENTRAL-PLUS
descr:           IP pools

Based in the UK, had problems playing a couple of albums and a Mood playlist via Tidal connect to a PiZero 2 with a Dragonfly Black 1.5 attached via USB.

Another way to test:
How to check if the ISP uses Carrier-grade NAT (CGN) | Remoterig.com.

Volumio 3
Ps audio sprout
Rasp. Pi Allo Boss 2 dac hat
Tidal connect
USA Xfinity
Gets hung up every other song. Tidal still works if I direct to play from device instead of DAC

So I have just tried setting Tidal to only play at the Normal bit rate for all songs regardless of the bit rate that seams to have solved the problem of getting stuck every other song. Although a real bummer not being able to listen at higher bit rate and paying for it.

Having the same problem - it was good this past week or so, but over the last three days its gotten to the point where tidal connect doesnt work at all…

Really need to have this fixed ASAP

I have been listening for 2hrs straight with no problems. So far the only fix I have found is telling tidal to only play in normal. Volumio seams to be getting hung up when tracks have different bit rates. Hope this works for you and volumio gets this solved

No issues set to HiFi with other Tidal Connect devices. Just Volumio.