Synology NAS mount issue

Many people encounter Synology NAS mount issue why Volumio not fix in Volmuio 3?

Volumio 3 Issues?

Please see: Volumio 3 issues: hints and solutions before posting a new issue.
(You’ll need to cut and paste the link)

----------------------------- Delete here & above before posting below -----------------

This is neither a Synology NAS, a Volumio 2 or a Volumio 3 issue.
There is nothing wrong, so nothing to fix.
I have been using a Synology NAS DS405 for years and never had an issue with it.
Sometimes problems are caused by people mixing up the use of ‘\’ (wrong) and ‘/’ (correct), not using the correct name for the NAS or not the right IP, or incorrectly specifying the share name etc.
In case you would like some help, please give us some more info.
Are you using cifs or nfs? Are you entering the parameters manually or do you use the browse method?
Would you share some system logs please?
Preferable right after your steps to reproduce the problem :slight_smile:

Some hints

  • To enable CIFS (SMB) on Synology
    Control Panel > File Services > SMB/AFP/NFS
    enable SMB
    Advanced settings
    set maximum SMB version = 3
    set minimum SMB version = 1
    enable “local Master Browser”

  • Share permissions
    Make sure user guest is added with read-only permissions (write permission does not make sense). Advanced Permissions should be left empty.

  • Using the Synology share with cifs (SMB) with manual entry

    • Enter an Alias, this will be shown in the Music Library later.
    • Enter the IP address of your NAS or use its name (e.g. MYNAS, no additions like ‘.local’)
    • Enter the share name
      Do NOT use Synology’s “Volume1” in the share name, just the share name itself.
      When you set up the NAS like shown above with maximum and minimum SMBversion, you can press “Save
  • Using Volumio’s Browse function

    • Use “Add Share” and wait until scanning has finished
    • Click “+” on the listed server which represents your NAS
    • Select the share you wish to use
    • When you set up the NAS like shown above with max and minimum version, you can press “Save

In both cases, when you left maximum and minimum SMB version default (untouched), then you need to add “vers=1.0” to the advanced option before pressing “Save