Synology hell (file not displayed)

I’ve very big issues working with a Synology NAS and I think Volumio need to pay some attention on this topic because Synology is a well known and quite widely used brand.

I was able to connect to NFS shared with the following tricks:

  1. You have to properly set permission for the NFS share, using . as the IP
  2. The main trick is that you need to connect to the /volumeX/share path, the simple share name does not work. The path is shown in the Synology interface

I was not able to connect in any other way,

Now the connection is green and Volumio shows that the share contains some TB of data BUT…


Any idea? Any command I can give using SSH to check how the connection is working?


These (attached pictures) are my settings to gain access to the Synology server via NFS.
I hope that helps you.
For me this worked fine. I set two NFS shares: the first with the IP-adress and the second with the hostname of the Volumio-Server to make shure that it works but normally the hostname would be enough.
Anmerkung 2020-01-22 180041.png

The key part there is the map users as admin. Otherwise the share content will not be visible.

I’ve hit that same issue before with other apps taking data from my Synology via NFS, and making that tweak fixed it there.

Why don’t you just use smb? I have a Synology NAS and smb works flawless with my music share.

Never had this problem with synology ds412+

Verstuurd vanaf mijn SM-G960F met Tapatalk