Switch off the screen on Volumio PC

Hi,
I’ve set up Volumio-PC on an old samsung netbook and it works just great. I know it’s not very energy efficient, neither “audiophile”, but until I get a raspberry with a DAC or something else, I am enjoying it.
I just wonder if there would be a way to keep the netbook screen off from startup, while being able to listen to the music and connect to volumio via network. At the moment, the screen is always on, and if I close the netbook, it goes automatically to standby, then Volumio stops. I wish I could just start volumio with no screen display.
Thanks for any help.

I reply myself after a few searches that helped me to solve this. I found several possibilities to do that.

My favourite one : Disable the hibernate function on lid switch
Connect to volumio via SSH as root, edit /etc/systemd/logind.conf and change the value of “HandleLidSwitch”

# HandleLidSwitch=suspend HandleLidSwitch=ignore
After rebooting, the laptop doesn’t power off when closing the lid, it just switches the screen off. What is great with this is that you still can open the lid and then you will get the screen on, being able to user volumio from the laptop. Of course, you can access volumio through your network and listen to some music with the lid closed.

Another solution
Write and set up a startup script including the following line

xrandr -d :0 --output LVDS1 --off

It works also well but if you want to turn the screen on again, you will have to disable your startup script and reboot, or for a one time shoot, you can connect via ssh as user “volumio”, then type

xrandr -d :0 --output LVDS1 --auto

To me, it’s just less convenient than keeping your laptop closed with the screen off and power on.

If someone needs more help to set this tweak up, just pm me.

Thanks for sharing this, perhaps we need a plugin for x86 doing tweaks like things like this plus cloning to hdd etc.
-Gé-

Hello. It didn’t work for me, but I found this solution…

touchscreen-plugin-turn-off-backlight-when-not-playing-t5457.html#p59470.

Hope it helps.

Regards.

Thanks a lot!

works like a charm.

That’s just brillant:-)
Thanks :slight_smile:

Mine just goes to some sort of powersaving mode after about 25 sec