Stuttering Qobuz streams

Volumio Information

Volumio Version: 2.861
Hardware: Usbridge signature
DAC: Musical paradise MP-D1 Mk3

I recently purchased Volumio Virtuoso to stream from Qobuz. Unfortunately however, when streaming high res files, the music begins to stutter violently and below error occurs in the log.
player: Decoder is too slow; playing silence to avoid xrun

Please let me know how to solve this. The purchase of Virtuoso is kind of wasted money now.

RX packets:84305 errors:0 dropped:13782 seems a allo driver issue…or a bad connection

Hmm interesting…
A bad connection seems unlikely as streaming these high res files on my macbook pro (wifi connected) directly over USB to the DAC gives no issues. The Usbridge is a wired connection directly to the main router…
Could it be the processing power of the Usbridge just isn’t capable enough to handle these large files?

the drops are on eth0 so the wired connection… so it could be a driver issue
but maybe @volumio have a anwser to this…

It could also be due to the CPU maxing out. During playback, check the CPU usage in the SSH console:

$ top

Note the %CPU value for the first row, see if it goes to 100%.


If that’s the case, try turning off resampling, set mixer to “None” and volume normalization to “Off” in Playback Options. If there is any equalizer plugin, turn it off as well. See if playback improves.