Still having trouble with volumio on WiFi becoming unresponsive

Volumio 2.909 running on an RPi 3B+ using only the WiFi connection. After a couple days uptime the device becomes unresponsive to Airplay or HTTP requests. I forced a reconnect using my WiFi router at 13:20 in the logs here: http://logs.volumio.org/volumio/qzhVLsv.html and everything begins functioning normally.

The last entry in the logs is a long series of the following entries. volumio wpa_supplicant[2424]: wlan0: WPA: Group rekeying completed with 06:ec:da:e6:e2:4b [GTK=CCMP] Are these related somehow?

Attaching an ethernet seems to fix the issue, but if a Airplay audio device requires ethernet to work, it’s not very useful. Any help is appreciated

The RPi3 wifi has a bit of a reputation for being rather poor, especially if you are using a metal case. If you can’t use ethernet, then try a USB wifi dongle in your RPi, or even a wireless repeater.

This seems to happen on my RPi Zero as well. I run other applications on my RPis just fine. Is there something perhaps in the config of Volumio causing this issue?

1 Like

Not that I’m aware of. Wifi is very convenient, but you have to take on board it’s limitations.

Bummer. If airplay doesn’t work with WiFi, what’s the point? I might as well just run a 1/8” headphone cable to the stereo.

Other distros run wirelessly on a RPi for weeks or months without issues. There are people who run Pi-Hole on an RPi zero for months with no connectivity issues. I wonder what they’re doing differently.

Any other hobby boards that work more reliably?

They’re probably ensuring that they have good wifi coverage at the points they are using their devices. From what you describe that you have tried, you are just expecting it to work automatically everywhere.

I’ve tried two different raspberries with multiple versions over the last year. Both are within 6 ft of the router.

Any other tests you might suggest would be helpful. I’d like to get this running more reliably if possible.

Just for future reference, please post as much detail as possible in your initial post when asking for help on the forum; it makes potential solutions much easier/quicker to find. :wink:

One would expect at this range from your router, that signal would not be a problem. However, you may be getting interferences from other households using the same wifi channel as you, or interference from other sources (??). You could try changing the channel used on your router. There are mobile apps available that allow you to monitor how congested the various wifi channels are.

If you feeling adventurous and can access the CLI, then you could get some numbers for the signal that your devices are receiving.

How to enable and use ssh.

At the command line, type:

sudo iwconfig

and look for ‘link quality’ and ‘signal strength’.

You could also monitor it continuously (to check for signal/quality falling away):

  watch -n 1 cat /proc/net/wireless

(Press CTRL-C to exit)

Happy hunting, not sure that I have more suggestions to make. Some people find that restarting their devices periodically helps.

Results of sudo iwconfig:

Bit Rate=58.5 Mb/s   Tx-Power=31 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=70/70  Signal level=-34 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:2  Invalid misc:0   Missed beacon:0

I watched watch -n 1 cat /proc/net/wireless for several minutes, no discarded packets. I’ll try monitoring for a longer period and report back

So, the signal at your device is excellent (as you would expect from it’s distance from the router). At least, in this snapshot.

Half the time when I want to listen via Volumio (on my Raspberry Pi 3b+), it’s unresponsive. I then have to power cycle the Pi and after a minute or so, all is well. I also have to kill the Volumio app if I switched away from it for another app and then return: the Volumio UI is a white screen so it has to be killed. Both of these bugs are very annoying. I just bought a microSD card to try Moode Audio on the same Pi (saving the Volumio microSD if I decide against Moode). Configuration of Moode turned out to be more difficult than it was with Volumio, but after viewing a 4-year old YouTube video, it’s set right and working. The UI is via a web browser. So I’ll try Moode for awhile and see how that goes.

I gotta +1 this as well. I’ve an RPi4 and Volumio on a very stable BT WholeHome WiFi mesh network that has multiple devices connected and almost never drops any of them. The closest repeater is no more than 3m from the RPi.
However, if I’ve left Volumio alone for more than a couple of days I have to power cycle it to get it back on the network. No idea why it’s happening but always hoping a new release of the image will fix the problem…