Stability issues on Raspberry Pi

I’ve been running Volumio on my Raspberry Pi for a couple of months now. I started with version 1.1, but found it to be slightly unstable. It would become unresponsive and stop playing, but I’d still be able to log in over SSH and reboot. This would “fix” the problem for a couple of days.

To see if stability was improved in 1.2beta, I recently switched to this version (full SD card re-install). It seemed to run better, but yesterday, it completely failed. The Pi went into “zombie” state, with no web gui, no audio and no SSH. Powering the PI down and back up did not help. The Pi would not get to the point where it connected to the network (not visible in Fing on Android).

Re-installing 1.2beta revived Volumio, which I guess rules out hardware issues.

Is anyone else experiencing with Pi’s running Volumio 24/7 (although not always playing music)? Any thoughts on why Volumio would randomly crash and be unable to boot?

Mine is on 24/7 and I had the same issue. I enabled crontab then I make the Raspberry Pi do the following around 6am (i.e. when I’m in bed and not using it): reboot, restart MPD, mount my NAS (ignore this if you don’t have issues with losing the mount), and finally update MPD database.

I haven’t had any issues since. Here are the steps I take:

sudo nano /var/www/command/

Look for the lines …

[code]if [ “$2” == “startup” ]; then

kill useless system processes[/code]

… then I added a “#” before “killall -9 cron” to prevent cron being killed (so it looks like this):

#killall -9 cron

Save and exit. Now that crontab is enabled from next boot, configure it to do the tasks:

sudo crontab -e

Then add the following to the bottom of the file:

5 6 * * * sudo shutdown -r now 20 6 * * * sudo /etc/init.d/mpd restart 25 6 * * * sudo mount.cifs // /mnt/NAS —verbose -o user=admin,password=password,rw,iocharset=utf8,sec=ntlm 26 6 * * * sudo mpc update

Don’t add the “sudo mount…” line if you don’t have mount issues. Note the timing system defined by the numbers: “5 6 * * *” is 6:05am, “20 6 * * *” is 6:20am etc so change these if you want it to happen at different times. Save and exit, then restart:

sudo shutdown -r now

Might not help but it solved mine!

Thank you. I will try that. Restarting things is far from an ideal solution, but if the issue is some sort of overflow/leak it might prove to be an acceptable workaround.

I have also been experiencing some various stability issues.

Out of curiosity, roytanck, are you running on Wifi? There seems to be a recurring issue I’m seeing throughout the forums with people using a USB Wifi dongle.

I have experienced the same “Zombie state” once or twice myself. For me it has resulting in having to connect a monitor and keyboard just so I could access a local terminal to reconfigure wicd.

I’m also experiencing some similar issues to what LeChuck is describing. The NAS mount issue in particular, which also seems to be USB network related (USB dongle takes too long to get an IP, so the initial NAS mount during boot fails, I also see the inverse happen on shutdown - not-able-reboot-because-nfs-unmount-failure-t901.html)

I’m using a wired connection, and other than these crashes, I have no issues. Mounts work well, and the web gui seems stable enough in 1.2beta.

I agree it’s far from ideal, but then I guess we are still in beta stage.