Spotify Connect2 on second Volumio device doesn't work


I have two Raspberry Pis running Volumio on my home network. From my Spotify app I can see and stream to my first Volumio device but not to the second one. I sometimes see the second Volumio in Spotify Device list, but I was never able to select it successfully. Any suggestion on how to debug this?

Plugin version: 1.0.3
Volumio version: 2.779

Welcome to Volumio francesco :).

Are all of your devices on a single network (in my house, I have a couple of networks to ensure good coverage)? I would think the mobile & Volumio device would need to be on the same network.

Hi! Yes they are. All on the same network. I even though that was the problem…

What is the Dac for both device? Same? Hardware mixer?

Hi, the RPi working with Spotify Connect mounts a Allo MiniBoss. The RPi that is not working with Spotify Connect has no DAC directly attached but is connected via USB to the AudioEngine D1 DAC which I use as headphone amp. It works fine except for Spotify Connect.

I suspect a problem with the volume mixer. Does your Dac provide a hardware mixer?
A log would help “journalctl -f’” to see what happens when you try to connect.
Btw, can you try to set a software mixer in Volumio and see how it goes.

You’re right!

Jun 25 11:29:29 deskbedroom volumio[30211]: thread 'main' panicked at 'Error setting up mixer!: Error("snd_mixer_attach", Sys(ENOENT))', /build/cache/git/checkouts/librespot-6f197fd632ef9380/659de68/playback/src/mixer/

I tried to set software and none but I keep getting the same error.

If you set the mixer to Software, then it should not be trying to find use alsa’s snd_mixer_attach

Could you share logs of just vls? (journalctl -o cat -u volspotconnect2.service) after you’ve set up the Software mixer in volumio playback options?

Thanks! It works! Now after I selected software instead of hardware, it started working (probably it didn’t switch correctly the first time…). What about the loss of quality it mentions in the popup? Is that significant…?

Select the Mixer Type: None = No volume control, Software = Volume control but loss of Audio Quality, Hardware = Best of both worlds, provides ability to change volume without loss of quality

Well, without looking at the logs, I can’t comment if your issue is just a misconfigured mixer, or if it’s that your device doesn’t have a hardware mixer. Would you know?

That being said, I’ve been noticing an increase in the number of USB DACs having wrong mixers names/setups.