Some issues here

Volumio Information

Volumio Version:2861
Hardware: Raspberry Pi3B+
DAC: Hifiberry DAC2 Pro

Hi,

I’m new to using a older Rasberry Pi (as also being new to Volumio), as dedicated music server for my digital rips of my CD’s. I did use for some weeks Volumio in combination with the default (so without the Hifiberry DA2 Pro), headphone output connected to my vintage Luxman Amplifier, love the Volumio interface and the way things are organized, with i.e. Spotify. The only setback, that I encountered at that moment, was that the reset function, mostly ended in a power disconnect and connect again. Nothing major to me, the times you need to reboot are rather low (normally).

Then I decided to take my RBPi, to a next level, and I bought a Hifiberry DAC2 Pro. Looked on some reviews on youtube, looked promising.

After installing the HAT, problems immediately started.
First the DAC2Pro, has no entry in the HW selection list, I found out that I need to select the previous version DAC+ Pro, also nothing major…
But then I run into more problems, ALSA HW topics, first HW1.0 and now HW2.0, I found out to toggle and reboot between old headphone and new DAC, but nothing is helping and the booting issue is now becoming also a topic, since I need to unplug and plug the power again and again (not sure if this is impacting the process???).

Now have (nice DAC???) that I can not use with Volumio. I tried another package (like Moode), this works with my package, but the interface has “area’s for improvement” to put it mild. So I have only two options at this moment, use the headphone jack on RBpi itself or switch to another system. I would prefer a third option, finding some help on this forum to get some help or preferable a newer version of Volumio that addresses the issue?

Hi There,

a small update from my side…

After trying again during last weekend and changing several things I finally got a more robust Volumio system. I swapped the SD card, the stick to copy the image to the SD card was swapped and the image itself was downloaded again … After this on first boot, I got audio out!! Then I found out, I had to wait for at least 1 minute (power off) before I can reboot the Raspberry Pi. So I was able to get my Hifiberry DAC2 Pro working after reboot. Great!!

I also found the reference of ‘force_eeprom_read=0’ that solved actually two of my problems… My DAC stayed available in Volumio and the reboot waiting time of 1 minute was gone!

So quite happy for now.

The only thing that is not working are some WebRadio’s, certain links, will ruin my Volumio and crash the access to my NAS and other WebRadio’s and Spotify. When deleting those (non-working) WebRadio stations, everything runs well!!

:smiley: :smiley: :smiley: