[SOLVED] WebUI Menu Items disappear & mount retry loop

Dear All

Newbie to the most excellent Volumio in need of some help. I got Volumio going on the RPi B+ with HifiBerry DAC+ thanks to Plasma25’s helpful advice at http://volumio.org/forum/volumio-for-raspberry-model-t1574-10.html.

Tried to mount a NAS drive in WebUI without success (I think Volumio didn’t like upper case in the NAS name or the guest account with no password), and now the WebUI will not load the Library, Network, Playback or System tabs.

The /var/logs/php_errors.log file is growing at an incredible rate repeating:

[29-Sep-2014 22:35:31 UTC] >>>>> mount string >>>>> mount -t cifs "//NAS/Public/Music" -o username=Guest,password=,rsize=8048,wsize=8096,iocharset=utf8,ro,dir_mode=0777$ [29-Sep-2014 22:35:31 UTC] [29-Sep-2014 22:35:31 UTC] >>>>> cfgdb_update(cfg_source,dbh,,Array) >>>>> UPDATE cfg_source SET name='NAS', type='cifs', address='NAS', remotedir='Public/Music', username='Guest', password='', charset='utf8', rsize='8048', wsize='8096'$ [29-Sep-2014 22:35:56 UTC] >>>>> cfgdb_read(cfg_engine,dbh,sessionid,) >>>>> SELECT value from cfg_engine WHERE param="sessionid" [29-Sep-2014 22:35:56 UTC] >>>>> cfgdb_read(cfg_engine,dbh,,) >>>>>

It looks like its locked in a doomed attempt to mount the incorrectly specified NAS. I have searched but cannot find a way of unmounting a (failed) NAS drive through ssh. Anyone - any ideas?


You can restore the original db. Please be aware you’ll loose all the settings you have (network, nas, mpd etc)

sudo apt-get update sudo apt-get install git cd /var/www/db sudo rm player.db wget https://github.com/volumio/Volumio-WebUI/raw/master/db/player.db sudo chmod 777 player.db sudo reboot

Then the error resides here


Don’t put / in front of the parameters and you’re good to go!

Many Thanks. That did the trick.!

This is how I did it - a more gentle way to fix the problem without having to delete the whole db.

root@volumio:/var/www/db# ls
index.php player.db
root@volumio:/var/www/db# sqlite3 player.db
SQLite version 3.7.13 2012-06-11 02:05:22
Enter “.help” for instructions
Enter SQL statements terminated with a “;”
sqlite> select * from cfg_source;
delete from cfg_source;

you can delete the erroneous entry, e.g.:
delete from cfg_source where id=1;

after done, quit SQLite:

You will then create the entry again.