[Solved] webui is gone after ./webuiupdate.sh


I upgraded my volumio installation today. Everything ran through fine but after the reboot the web UI of volumio is gone. If I call the usual URL volumio I just get a blank page (no 404). Do you have any ideas what could be wrong with my setup?

Best Regards,

try to access the Volumio Web UI over the IP Adress

I didn’t even know there was an update script. Having a look at it, it seems that it takes the latest GIT repo. So, you’ll probably have an outdated DB (because it’s not under GIT anymore).

To fix that, go under /var/www/updates and run update.py

@michelangelo, it looks like the script webuiupdate.sh should be modified. It should not delete /var/www + clone repo when “/var/www/.git” exists, but just run “git pull” and then update.py

Hmm… good to know. Is there any other good/recommended way to keep the volumio web ui up-to-date? The 1.4 version that comes with the image download contains an annoying bug that makes loading-times on mobile devices terribly slow. And anyways I would be very happy to get the latest commits from the git repo. Is it recommendable to just run git pull in /var/www/ ? Or is there any other mechanism (planned)?

Best Regards,

We’re working on some automatic updates, but for the time being, if you run “git pull” then it should be ok. You may be asked to run updates when you open the webui, it’s not pretty yet (this ‘update’ feature has no theme at all) but it should work. Let us know if you encounter issues… But keep it mind that if you take the latest from git, then you’re a kind of beta-tester :wink:

Running “git pull” in /var/www on a practically brand new flash of Volumio 1.4 for Cubox-i4 gives me an error:

root@volumio:/var/www# git pull
Updating 99a48d5…f92c6a5
error: Your local changes to the following files would be overwritten by merge:
Please, commit your changes or stash them before you can merge.

Wondering where I can find info on how to update the Web UI for this platform? Also, on the stock 1.4 install for Cubox, there is no “updates” directory in /var/www, and therefore no “update.py” script to run.

You need to “git pull” before you can have the “updates” folder.
The error you get is because the DB was previously on GIT (and that’s exactly why we removed it). You must know that you would loose your settings when you update, it’s up to you if you want to do it or not. To get rid of this error just do:

git checkout -- db/player.db
git pull

The first line will abort any changes made locally in the database (that’s why you’re going to loose your settings)
The second line will then work.

Once this is done, future updates won’t break the database.

Thanks Jotak - those instructions worked.

I had to install sqlite3 (and upgrade the apt-get sources to jessie to do so) - it’s not on the stock volumio install and the update.py script requires it. After I did all that, seems to work fine! I am missing some icons in the new UI but I presume these are things missing in the dev branch. Mostly the new UI works and is faster at file browsing than the stock 1.4 UI.

Looking forward to future updates!

About the missing icons, this is most probably due to your browser cache. Try to clear it, and it should be fine

Yep, exactly that - browser cache issue.

New UI is working great!

Thanks Jotak and others for all the great work!