[SOLVED]Volumio 2.185: problems with spofity plugin, search

Since updating to 2.185, the Spotify plugin doesn’t seem to work any longer. And the youtube plugin doesn’t work at all (message: “An error occurred browsing the folder”.

Also the search functionality is not working any longer. If I type anything in the search field, nothing happens at all. Is it my install or the new update?

Yep. Same problem here. Spotify and youtube does not work.

Same problem here :frowning:

Please do this:
enable test mode:
volumio.github.io/docs/User_Man … dates.html
See: Use the system updater to test Beta-Releases

update to latest dev version.
Retry what you were doing. If that does not work please send a log:
volumio.github.io/docs/User_Man … oting.html

and paste here the URL. Thanks, we need those info to solve the issue

I went to test mode and installed 2.186.
This did not solve the problem. It got even worse: now the Youtube plugin is not even visible in the ‘Browse’ window.
And in version 2.185, the spotify section ‘My playlists’ worked but now it does nothing.

I tried to send a log from volumio.local/dev but after pressing the ‘SEND’ button, nothing happens at all.
So I don’t get a logfile?

It seems that you don’t have internet connection then. Could you post a screenshot of your network settings page?

I have internet connection. I just upgraded from 2.185 to 2.186 so the internet connection is working fine.
The RPi is connected to my LAN. But here goes anyway.
Screenshot from 2017-06-08 18-53-31.jpg

Ok, can you please try to uninstall and then reinstall the plugins?

Reinstalled the plugins. NO change in behavior. Spotify still does not work. Youtube plugin does not work.
Search does not work (also no search on my own music on my NFS mounted volume. Playback from NFS works normally.
But this is not related to the Spotify plugin I would think. Maybe the Spotify plugin works, but the problem is in search?

Anyway: “My Playlists” in Spotify works again. But not searching and the other options “Feature playlists”, “What’s New” and “Genres and Moods” don’t respond.

Could you retry to do a search and send logs (remember to fill a brief description for it)

When I click the ‘SEND’ button in the Volumio Test Player ( nothing visibly happens.
So there is no URL with the output to paste or link to send.

By the way: I upgraded to version 2.188 now. No change. Will now update to 2.189.

Upgraded to version 2.189. Reinstalled plugins: no change.

Usefull information: the search functionality works as expected when the spotify plugin is disabled.
So the search is somehow disabled by the spotify plugin. I think this might help looking for the solution.

Could you try to set the IP as automatic again, then reboot enable the spotify plugin and see if that works.

Set IP to automatic, rebooted.
No change. Still not working.

Something else: the error message from the Youtube plugin “An error occurred browsing the folder”, doesn’t show when the spotify plugin is disabled.
But for the rest the Youtube plugin does not do anything either. If I click ‘Youtube’, an empty window appears.

I sent another log. I don’t know if you receive them.

Upgraded to V2.191
Uninstalled plugins Spotify and Youtube
Reinstalled plugin Spotify but not Youtube
Still no change. I just sent a log again.

Some observations:

  • Even though the Youtube plugin is not installed, it is still visible in the Browse window
  • (see screenshot): after upgrading to 2.191, still on the ‘system’ page, V2.114 is listed as ‘system version’
    Screenshot from 2017-06-09 13-26-46.png

Meanwhile version 2.193. No change. Still not working. Sent a log again.

Your system looks broken, you’re still on an old version. Sorry, but you need to reflash Volumio

I reflashed Volumio. Problems solved. Everything works now.
Thanks @Michelangelo!

Glad to hear that!

I went through the updating process and still the older software is in the system (2.114)