[Solved] Volumio 1.5 + HiFi DAC PiCobber = terrible sound

Raspberry Pi B
HiFi DAC PiCobber from Geekaroo
NAD C352 Amplifier
B&W 804 speakers

I installed the latest Volumio (1.5) and selected the HifiBerry I2S driver and software volume control. I left all of the other settings at the default. The sound coming out of my speakers is barely recognizable. It isn’t just occasional pops or dropouts but more like the sound is completely garbled. I tried airplay from my Macbook running Spotify and various mp3’s off of a USB stick all with the same results. I also tried the 3.5mm and RCA jacks from the PiCobber.

I switched back to “None” for the I2S driver and plugged the Pi’s analog audio out into the NAD. It sounded fine–at least as good as the Pi’s analog out ever sounds.

I am an experienced EE with a professional, temperature controlled, lead free soldering station and I inspected all my joints under a magnifying glass so I don’t think the soldering is the problem.

Any ideas what might be wrong? Is this a software configuration issue?


Install version 1.51 for rpi
There was a problem with 1.5 version

try Volumio 1.51 (http://sourceforge.net/projects/volumio/files/Raspberry%20PI/1.5/Volumio1.51PI.img.zip/download)

The image that I downloaded yesterday is named Volumio1.51PI.img but the credits screen and the motd when I ssh say release 1.5. The “Check Updates” on the system page does not report any updates to install. I think this means that I already have 1.51.

I did see the issues with high resolution files on the forum, but I am playing cd quality 16 bit @ 44.1 kHz.


Guess this is a driver issue then. I don’t own your DAC so cannot confirm.
Try to change driver and let me know. I would try IqAudio, then generic…
Let us know

I tried all of the other I2S drivers and didn’t get any sound at all from them. I also tried lower resolution mp3’s and some apple lossless m4a’s I only get sound with the HiFiBerry driver and it is all garbled.

Thanks for trying to help and let me know if you can think of anything else.


PiCobber - this is Hifiberry DAC !!! I still play well on it. Poor reproduces only DFF files and FLAC 32/384.
Format your card and re-install the system.


Audiophonics.fr Raspberry DAC 32/384

PiCobber DAC

Find 10 differences ??? ))))

I found 14 and i wasn’t even trying :stuck_out_tongue:

But you dont have to look for defferences, just at the chip that is used :smiley: there all called the same pcm 5102A :nerd:

French DAC & PiCobberDAC - one and the same.
Write about Hifiberry , that there’s so special ?
…And we’ll read ) Please )

I formatted and reinstalled several times. always the same problem


2 Last things I would check:

  • Change PSU, use a good quality one, at least 1A
  • Disable software mixer (set Hardware or None).

After that, I think this could be an hardware problem…

Are you sure you install version 1.51 ???

I even works with “Software” mixer ON…

I have power supply adapter 12V 1,5A >>>

convert in 5V

Thanks for the tip Michelangelo. It was the power supply. The one I was using is rated for 1A, but it is a cheap one and the rating is probably not true. Anyway, swapping in a different power supply fixed the problem and now everything is working great. I appreciate all the help.