[SOLVED] Update to 2.175 -> empty screen


my config:
raspberry pi 3 - allo Boss - Network with cable

after updating to 2.175 from 2.136, it still works from the PC perfect.

on the Android Handy (sony XA Ultra), i got only empty Screens (White).
before update, it works with the Handy

i have a second raspberry w/o allo Boss, which i do not update.
Android with browser works still perfect on this unit.

any ideas?

You don’t say what the app is that you are using on your phone, but it is here that you need to look. Double check that it has the correct IP address.

i use the Standard browser from android, Chrome 58.0.3029.83
on PC, i use IE11

i just check it wih Chrome on PC
2.175 doesnt work
2.136 work

and now, after some hours, it also doesnt longer work on PC


IP is definitly OK

There was a problem doing OTA updates from earlier versions, but I forget how far back that was. You might like to do a search, or just do a new flash with 2.175.

doesnt have the user then Troubles with ssh or so?
and also, when i read the threads in the last months correct,
the update Problems shold be solved Prior 2.136?

i have no Problem to Login in per SSH
i will wait 1-2 days, maybe someone of the developer have an idea or Need some infomation from the unit

btw when i start the update via the browser on a PC in the volumio UI:
i dont think, it has anything to do with OTA update.
if i understand that correct, OTA is for android Firmware.

Looks like, that the update process doesnt run “clean”

i find out, that (at minimum) the “/volumio/http/WWW/index.html” was NOT updated.

in this file, there is a link to:
{script src=“scripts/app-1d542807b9.js”}{/script}

but this file does not exist on the updated Version.

just make the update on my spare raspberry.

copy the index.html to my main raspberry

it run again

it looks like, that the web update process does not work correct, when a file was changed!

i made a Change in the title tag for test porposes in the index.html

This explains everything. You modified a file of the UI, and by doing this you broke it.
The OTA updater works, but if you edit a file, this won’t get updated. Since the UI is dynamically built, you basically broke up its file structure.

volumio.github.io/docs/User_Man … dates.html

Considerations over OTA Updater
If you’re an advanced user and do usually manual settings to the system (e.g. manual changes of config files via SSH, update volumio backend via GIT etc) , we strongly suggest not to USE the OTA updater, since your manual changes will impact the consistency of the updates