[SOLVED] Stuck with Allo Piano 2.1 on RPi3

Hi all,

This week I received my Allo Piano 2.1, Allo Kali, Allo CM and Allo Amp. Connected the whole stack on top of an RPi3. Alas, can’t get any audio.
I’ve tried lots of Volumio images, tried all kinds of settings, but to no avail.
I use the Allo 3A power supply, so that should be sufficient. Also tried reflashing using brand-new SD cards.

To pinpoint the problem, I’ve got only the Piano 2.1 connected to the RPi3, so without Kali, Amp and CM.
I don’t expect audio now haha, but when playing mp3 from my NAS I get the following error message:
Failed to open “alsa” [alsa]; Failed to open ALSA device “softvolume”: No such file or directory.

I can only select “Software” or “None” as mixer type. Shouldn’t “Hardware” or “Digital” be available to select, too?
When executing the command “aplay -l” in the console, the Piano doesn’t appear.

I’ve got the compatibility switch set to “on”, although it doesn’t seem to matter regarding my issue.

So I’m guessing maybe it’s the hardware? Are the Piano and RPi3 supposed to get very hot? I’m guessing the Piano reaches roughly 50 degrees Celsius, and the RPi3 even hotter.


Just to verify…what do you have in “playback options” ? In “audio output”…

Looks good, is it possible to connect RCA of Piano 2.1 to an external amp ? You should have sound…

Use any radiostation…NAS I cannot troubleshoot

Any updates ?

Sorry for my late reply. I picked up a new board from my local vendor, and that one works perfectly (same Pi, same config).
So the first board seems defective.