[Solved] Problem with usbmount

Hello to everyone,

I am using Volumio 1.4 and I am having problems with usbmount.
When I insert the USB flash drive it is correctly recognized by the kernel (I can see that with dmesg
but nothing happens, i.e. the drive is not mounted. df does not show /dev/sda1 as
being mounted and /mnt/USB is empty.
The drive is working correctly as I can successfully mount it manually with mount /dev/sda1 /mnt/USB.

I cannot figure out why usbmount is not doing anything; anyone experienced similar problems?




connect the usb stick before you boot

I will try that as soon as I come back home, and that should work.
Unfortunately it is not the solution I am looking for, as I would like to have, for example, friends coming over
with their USB stick, and just connect it to Volumio, update the DB and start playing, without having
to reboot.
For what I understand usbmount should indeed be able to do that, detect when a new USB storage device is inserted
and mount it automatically WITHOUT the need to reboot.

Problem solved :wink:
For some reasons it seems that udev is not running on volumio 1.4.
By manually starting it (i.e. sudo /etc/init.d.udev start) the insertion of a USB memory device is
correctly recognized, usbmount script called and the device mounted in /mnt/USB.

I am experiencing similar problems.
Volumio 1.4 with latest MPD and Shairport Sync up and running perfectly.

Currently I am trying to get Volumio to shutdown when my USB DAC is turned off. The udev rules work when I manually start udev, but after a power cycle I have to restart udev again.
Kernel events are triggered but no USB events and my rules are not loaded during a new boot sequence.
Any idea for a workaround or how to fix startup behaviour?
I do not want to manually start this on each boot as I have 3 volumio devices running.

I found a solution:
some services, among which udev, are killed at startup by script:
just remove the line where udev is killed and it should work.



Thanks Luca,

It worked perfectly!
I will post a detailed how-to guide in the tweaks section this weekend in case someone has similiar issues.