[SOLVED] No LAN and Wifi connection

Hello,

I’m using a Raspberry Pi 3 and Volumio 2.201.
I can access volumio with the WLAN hotspot all the time by the Mozilla Firefox browser without any issues.

I can not access volumio with LAN or WLAN, I have rebooted the system 15 times without any success.
Ethernet cable is ok, other devices work well on that connection.
I have tried static IP and dynamic IP at volumio network settings, when I disable the volumio hotspot is does not work as well with the Ethernet connection.
On my FritzBox router I do not see volumio either.
The green and yellow LEDs are flashing cyclic at the same time on the Pi.

Have I missed something ?

Volumio Hotspot feature it NOT meant to serve as a home router: it is merely a feature to easily connect to Volumio locally and do networking setup, save and restart with new setup.
So Volumio should have direct connection to your Home router either via Ethernet port or Wifi (for that you would disable hotspot once proper SSID/pass are set in Volumio UI).
Please check the doc link in signature.

This was my understanding as well. Set up the network via volumio hotspot and once the ethernet is working, the hotspot can be disabled.
But I don’t get a working ethernet connection.

If you have ethernet, forget about hotpsot, it should be simpler.
Your Cable/DSL router has DHCP I assume, and own interface to display what is connected to home network.
When Volumio is running, don’t you find Volumio device IP on the router interface?
Using another machine on the network, can you fire-up a browser and open a web page at that adress (or to volumio.local if you have a Mac/iPad/iPhone)?

Correct, my router has DHCP and I see all other devices and their IPs, which are hoocked up to the network.
But I don’t see volumio.
I have the impression that volumio also causes issues to my network, I have problems with accessing the homepage of my router when the PI is powered.

Can you start-again fresh, reflashing brand-new image on SD.
Add an empty “ssh” named file on root of SD (no extension).
Connect ethernet cable, then boot device with SD
Allow first boot some time (about 8mn) before touching any configuration.
You should then see it on the network.
Do you have a chance to connect your Pi to a HDMI screen and USB keyboard?

Can you start-again fresh, reflashing brand-new image on SD.
Yes I’ll try.

Add an empty “ssh” named file on root of SD (no extension).
Just ssh without extention like txt , cfg etc. ???

Connect ethernet cable, then boot device with SD
Allow first boot some time (about 8mn) before touching any configuration.
OK

Do you have a chance to connect your Pi to a HDMI screen and USB keyboard?
HDMI screen and keyboard is possible. I don’t have any experience with Linux :confused:

yes, just as I wrote, no extension…
During boot, you will see messages on the attached screen: IP address should show-up (but read quick!)

I did the first steps, new image, and ssh file. After 15 min I still do not see volumio on the FritzBox.
Later on I’ll try to connect a screen and keyboard.
My SD card has 32GB and class 10. Does this card work ?

SD spec is all good. Can’t tell if that particular one is fried or not (if you have another one try it).
How do you flash it: Etcher is quite reliable tool for that.
Now once screen is attached, you’ll see the boot sequence happening (or not if SD is that bad).

I’m using the win32DiskImager

I have connected a screen. When powering up the system I see some boot information from the kernel, but there is no hint to network connection.
After boot process is done I see on the screen:
volumio login:

This is the interface for the command line, right ?
How to proceed now ?

You may log-on (user/pass as volumio/volumio) and report output of:ifconfig cat /etc/network/interfaces cat /etc/resolv.conf sudo iwconfig

eth0
link encap: Ethernet HW address b8:27:eb:00:96:3e
up Broadcast Running Multicast MTU: 1500 Metric: 1
RX Packets: 0 errors: 0 dropped: 0 overruns: 0 frame: 0
TX Packets: 14 errors: 0 dropped: 0 overruns: 0 carrier: 0
collisions: 0 TX queuelen: 1000
RX bytes: 0 TX bytes: 5474

IO
link encap: Local Loopback
inet addr: 127.0.0.1 Mask: 255.0.0.0
up Loopback running MTU: 65536 Metric: 1
RX Packets: 88 errors: 0 dropped: 0 overruns: 0 frame: 0
TX Packets: 88 errors: 0 dropped: 0 overruns: 0 carrier: 0
collisions: 0 TX queuelen: 1
RX bytes: 9538 TX bytes: 9538

wlan0
link encap: Ethernet HW address b8:27:eb:55:c3:66
inet addr: 192.168.211.1 Bcast: 192.168.211.255 Mask: 255.255.255.0
up Broadcast Running Multicast MTU: 1500 Metric: 1
RX Packets: 10 errors: 0 dropped: 6 overruns: 0 frame: 0
TX Packets: 50 errors: 0 dropped: 0 overruns: 0 carrier: 0
collisions: 0 TX queuelen: 1000
RX bytes: 625 TX bytes: 9461

auto wlan0
auto IO
iface IO inet loopback
allow - hotplug eth0

iface eth0 inet dhcp
allow - hotplug eth0
iface eth0 inet dhcp
allow hotplug wlan 0
iface wlan0 inet manual

#Generated by dhcpcd

open DNS nameservers

nameserver: 208.67.222.222
nameserver: 208.67.220.220

wlan0: IEEE802.11 bgn Mod: Master TX Power = 31dBm
retry short limit: 7 RTS thr: off Fragment thr: off
Power management: off
IO no wireless extensions
eth0 no wireless extensions

The ip address 192.168.211.1 looks like the hotspot address.
All other ip addresses I have never seen. The gateway ip of my router is completely different than anything from the log above.
Do you have any idea how to proceed ?

Strange Ethernet side seems totally mute.
Have you tried connecting another machine into that same ethernet cable, and checked it got proper IP address and internet access?
Other test: is you Pi getting valid IP address it you run a Raspian SD?

Before I have changed my Pi to Volumio I used Max2Play with the same Ethernet connection, cable etc.
I will try to use an other Ethernet connection and switch back to Max2Play for testing.
But remember, I even can not set up Volumio to work with my WLAN. Just the hotspot is working.
I have spent many hours up to now :frowning:

I have noticed a real strange behaviour.
Oncemore I tried to connect volumio to my WLAN.
Suddenly the LAN was connected to my network with the same cable and access I’m trying since days.
Futhermore I see now the IP Address in the UI at the wired network status.
After that I have disabled WLAN and hotspot and it is still working.
Maybe there are some bugs in the UI or the network kernel.

To disable Hotspot, there is a dedicated UI switch to turn it OFF.
Good that you now have network access: you may mark this topic as resolved.

How to close or resolve this item ?