[Solved] No audio output from Raspberry Pi headphone jack

Title says most of it… I apologize if this is a common problem/fix, the search function kept ignoring my search terms.

My installation of Volumio 1.5 on my Raspberry Pi (Model B - Rev 2) boots, is accessible via web interface, appears to see/play music, but I’m getting no actual output from the 3.5mm audio jack. I checked alsamixer to make sure it wasn’t muted (it wasn’t).

EDIT: Okay, it turns out, I’m just not very bright, so for others who end up with the same problem, I will enlighten you. If you’re using the HDMI output to monitor things, well, guess what? That’s where your audio is going. Unplug your HDMI, problem solved.

The only failure I’m seeing at boot is:

"startpar: service(s) returned failure: transientlog ...cat: /run/player_wrk.pid: No such file or directory"

I’ve tried nothing, and I’m all out of ideas! :confused:


Woah! that must be moved to [Guides] , I’ve messed around for hours!

I found a great simple hack in raspberry forums ( raspberrypi.org/forums/viewt … 91&t=40872 )

:smiley: yes !!! solved my problem! many thanks

Created an account just to say thanks for this.!