[Solved] NAS mounted, can't see music

Hi all,

I’m an absolute novice and would be extremely grateful of any help anyone can give…

First, I’m loving Volumio! I’ve been using it for web radio and airtunes for a few weeks and have decided to buy a NAS so that I can get it up and running with my collection.

After some trial and error, I have finally managed to get my new Synology NAS to mount (I have a green tick!) however, I can’t see any of my music or containing folders in Volumio :frowning:

I’m not sure if it’s a problem with Volumio settings or the Synology NAS settings but I’ve followed the instructions in Futura’s March 02, 2014 post (experience-getting-volumio-going-t746.html) for both, to the letter, and it’s not working.

This is my NFS configuration:
Volumio NAS settings.png
Mount flags nfsvers=3,ro,noatime,intr
Rsize: 32768
Wsize: 16384

I’m running Beta1.4

Thanks in advance for any help anyone can give, I’ve trawled through the forums but haven’t found a fix yet.

Already updated your MPD Database?
Sometimes Volumio have no right to access the music files from your NAS.

Remove volume1 and leave just music.

Thanks for the help so far.

I’ve tried removing volume1 and leaving just music but that doesn’t work and the mount fails.

I think it might be to do with the settings on the NAS, would it be easier to set up a SMB share?

Thanks again.

Check here

It’s worked!!

I’ve set it up over SMB as per your advice and now it’s working great!

I don’t know why it wouldn’t do NFS, I tinkered around with it loads and got nothing but SMB worked straight away.

Thanks all for your help :smiley:

Please write your configuration and the final advanced options you used in that thread, so that other people will not need to try and can just go straight to the solution.

I have been successful in getting MPD to see music over NFS mounts with the information in this thread:


Note the last post about the executable permission on the music directory - without this, MPD will not index the music files.

If you can get NFS working, it’s likely preferable to SMB mounts as it’s more performant. Certain platforms, like the Cubox, supposedly have some performance issues with SMB mounts.