[Solved] mp3 issues and volume control with hifiberry digi+

Hello to all,

My initial set-up with a Rasberry Pi B+ and Volumio was using the HDMI sound output from the Pi through an external DAC, and everything was working flawlessly.
I just added an hifiberry digi + add-on board, used the volumio system setting menu to declare the hiberry digi+, connected the digi+ board to the DAC with a Toslink cable, and started to listen to a few pieces from my USB hard disk. So far so good.

However, my user environment is not as perfect as before:
-I cannot operate the sound volume control, frozen at 100.
-I can listen to all the music files in the .flac and .wma formats, but no mp3 files can be accessed any longer.

I would really like to make everything work, since the sound from my amplifier through the hifiberry digi+ seems to have gained some depth and clarity (subjective feeling of course). Since I was not able to find posts related to these topics in the help forum, I am sending this message.

Is it expected that the sound volume control becomes unusable once the hifiberry digi + is set?
Have other people had the same issue with the mp3 files? Do you know of any solution to access the mp3 files again?

Thanks in advance for the time you guys will spend to answer. Volumio is a very useful and well-done tool, and I hope my questions will help make it even better for this specific configuration.


For the volume control, you’ve got 3 possibilities :
With the Hiberry digi+, It seems (I havent got this dac) it support hardware volume, so set Volumio to hardware and should be ok. :smiley:
edit : sorry I read to fast, does your problem occur with others files (flac ?) or just for mp3 ?

Thanks Balbuze for the tip.
In fact, it seems the hifiberry digi + does not support the hardware setting for volume control, but I tried the software setting and it works fine.

Regarding the mp3 files that could not play, I tried playing with the General music daemon options and with the resampling settings and somewhere in that trial and error process the mp3 problem disappeared. Now I cannot even recreate the issue with the initial setting I used.

So I cannot say I understand what happened for the non-playing mp3 files, but my issues have gone away.

It was a pleasure using this forum, and experiencing the willingness to help of the volumio community. I hope a few other users will learn from my issues as well.

Regards to all,