[Solved] Equalizer

Hello! Any suggestions for audio equalizer?

many tanks from Brazil!

I’m thinking on that… But will take lot of time before you see it on Volumio…

I would really really love an equalizer. I have a crappy speaker in the kitchen and my only option is an EQ. It would be awesome if it could be software.
I’d be happy to contribute in any way. And I’d rather spend my money and time on supporting this project than just go buy some better speakers.

Guess ecasound will be the way…

Is that an DIY-suggestion? It looks promising.
I’ve worked on some VST’s through SynthEdit some years back and will be happy to give it a shot if nessasary.

You are awesome BTW :smiley:

Hi folks,
I installed alsaequal from here http://www.thedigitalmachine.net/alsaequal.html.

From command line I can play a wave file and change the frequencies in the equalizer, e.g.

alsamixer -D equal

Now I’m struggeling with the mpd.conf. I created following .asoundrc file at user pi

[code]ctl.equal {
type equal;
}

pcm.plugequal {
type equal;

Modify the line below if you don’t

want to use sound card 0.

slave.pcm “plughw:0,0”;

or if you want to use with multiple applications output to dmix

slave.pcm “plug:dmix”

}

#pcm.equal {

Or if you want the equalizer to be your

default soundcard uncomment the following

line and comment the above line.

pcm.!default {
type plug;
slave.pcm plugequal;
}
[/code]

The mpd.conf file I modified as follow:

[code]audio_output {

             type           "alsa"

name “Output”

             name           "equal"
            device         "plug:plugequal"

device “hw:0,0”

            dsd_usb        "yes"

}
[/code]

Unfortunately there is no sound at the sound card output.

Are there any suggestions, what I made wrong?

Regards
Holger

B.t.w. I did not use the web UI since it seems that the mpd.conf file will be overwritten after restarting mpd.

Hi Holger,

if you use GMPC, you could switch the output to equal. Maybe you have to start the plugin with command “sudo -H -u mpd alsamixer -D equal” to take effect. Good luck!

Klaus

@ Klaus
Thank’s! This command works! :smiley:

I also found out, how to manipulate the frequencies from the command line, e.g

sudo -H -u mpd amixer -D equal set '09. 8 kHz' 0%

Now it would be interesting to do following things:

  • add a site to the web gui allowing
    - to manipulating the frequencies
    - to store and retrieve the equalizer settings into/from the album folders

Are there any tough web programmers, who could create such a site?

Regards
Holger

Hey everybody,

i’ve just started my attempt to use alsaequal. after trying to compile it on my own, i realized that i can install it via

apt-get install libasound2-plugin-equal

after doing so, i was able to run alsamixer -D equal
i created the .asoundrc and changed /etc/mpd.conf
and i saw all the channels. but since i did so, i was not able to play any sound from volumio anymore. any idea what i can do?
are there log-files i can check?

Thank you for your advice!

Cheers,
Thomas

Oh, i forgot to mention that i am using a HifiBerry Amp…

Cheers…

Hi all,

since Volumio could run squeezelite, is possible use every feature in LMS, give a try to InguzEQ plugin.

Marco.

Are you sure you selected the correct audio output?
Did you upgrade packages during installation? this could trigger some errors

not by intention… i just installed caps and the alsaequal package…

nobody an idea what i could do in order to troubleshoot?

ok gents,
as soon as i modify the mpd.conf i have silence.
Can anyone tell me what is going on with the logs in volumio?!
/var/log/ messages or syslog are emtpy and ./mpd/mpd.log is just logging the 127.0.0.1 connects…

Cheers,
Tom

hm, what i did not mention is, that as soon as i change the audio_output section to

[code]audio_output {

             type           "alsa"
             #name          "Output"
             name           "equal"
             #device        "hw:0,0"
             device         "plug:plugequal"
             mixer_control  "Master"
             mixer_device   "hw:0"
             mixer_index    "0"
             dop    "no"

}
[/code]
i cannot even “play” a song via volumio.local. it does not start…

Hello alltogether,

i dont know why, but now it works :slight_smile: so - but lets start from scratch, for others to follow :slight_smile:
I own a Raspberry Pi and a HifiBerry Amp. In order to tweak the sound of this little combo, i wanted an equalizer, so this is how i did it:
First, a fresh install of volumio, then
Refresh the RPi stuff:

rpi-update

then, go to your volumio.local via a webbrowser.
Start with the Menu->system part and choose the “Hifiberry Amp” and klick on “Apply”.
Then, do a reboot, either via the Menu in your browser or

shutdown -r now

Unfortunately the mixer is not set properly in the mpd.conf, so you will not be able to adjust volume via the webinterface - it will always jump back to 100. if not, check the Menu->Playback part in the webinterface and make sure you choose “Mixer type” “Hardware”! Otherwise, the sound-quality will be poor. we will fix the Volume thing in a minute :wink:

Update the package chache

apt-get update

Install alsaequal (this will also install caps

apt-get install libasound2-plugin-equal

Find out which soundcard you want to output to:

aplay -l

for me, the output looks like this:

root@volumio:~# aplay -l **** List of PLAYBACK Hardware Devices **** card 0: sndrpihifiberry [snd_rpi_hifiberry_amp], device 0: HifiBerry AMP HiFi tas5713-hifi-0 [] Subdevices: 0/1 Subdevice #0: subdevice #0
Remember the card*

Set the configuration for alsa - i decided to do that system-wide via asound.conf (you can do that user-specific via /home/username/.asoundrc, but as i was a little confused that mpd is running as user “mpd” and i did not have a mpd home dir, i thought, “why not system-wide”) :

nano -w /etc/asound.conf

In the file, past the following:

[code]ctl.equal {
type equal;
}

pcm.plugequal {
type equal;
slave.pcm “plughw:0,0”;
#this is where you have to input the number of your soundcard, so card0 = plughw:0,0 - card1 would be plughw:1,0 etc.
}

pcm.equal {

Or if you want the equalizer to be your

default soundcard uncomment the following

line and comment the above line.

pcm.!default {

type plug;
slave.pcm plugequal;
}[/code]

Then i thought its a good idea to backup the configuration of mpd :wink:

cp /etc/mpd.conf /etc/mpd.conf_bak

then you have to edit the mpd configuration, specifically the audio_output section:

nano -w /etc/mpd.conf

[code]audio_output {

             type           "alsa"
             #name          "Output"
             name           "equal"
             #device        "hw:0,0"
             device         "plug:plugequal"
             mixer_control  "Master" #This is all the magic to fix the volume issue ;-)
             mixer_device   "hw:0" #this would have to be adapted in case your soundcard is not card0
             mixer_index    "0"
             dop    "no"

}[/code]

So, now your system is configured to use alsaequal. now reboot:

shutdown -r now

once the system is back, play a music file via the webinterface.
then run

sudo -H -u mpd alsamixer -D equal

and configure your sound as you want it to be…

If all that did not work out, try to add the user mpd to the audio group. I did that at some point during my fiddling:

usermod -aG audio mpd

What is rather strange, volumio refused to play anything in the beginning, so i stopped for a few minutes. without changing anything it suddenly started working - no clue why. Would be glad to hear if it works for you!

Cheers,
Thomas

Thanks for this guide Tom1502,
I just followed it to test it and it works. I didn’t had to add mpd to the music group and i didn’t had to wait before it worked.
I’m just using a simple usb upnp soundcard so it could be a hifiberry thing…

[spoiler]Now im going to disable this all, i hate equalizers :mrgreen: Im only able to make it all sound worse no matter what type of equalizer :blush:[/spoiler]

Thanks for the guide too; works perfectly on my HiFiberry amp+

As this is your First Post here, you registered just to say thanks? A pleasure :wink: