[Solved]Can't install mpdscribble on Volumio 1.3 or 1.4

I’m unable to install mpdscribble (for last.fm scribbling) on Volumio 1.3 or 1.4…

root@volumio:~# sudo apt-get install mpdscribble
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 mpdscribble : Depends: libsoup2.4-1 (>= 2.4.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I’d love to upgrade from Volumio 1.2 but this is stopping me. Does anyone have any ideas?

Hi zefer,

we are a few having faced the same problem since volume 1.3.
You can see my post here :


In the same thread you will find some other persons describing your problem.

Here is a solution suggested by Michelangelo :


To do so you should try to update “/etc/apt/sources.list” as explained by Michelangelo on this page :


Let me know if it works :slight_smile:

Awesome, thanks for this very useful reply @esseki. I’ll give this a try later today or this week and report how I get on.

Unfortunately, this did not work.

After updating my sources.list to use the jesse repo, I installed the missing keys (as apt-get update failed the first time), like so

sudo apt-get install debian-keyring debian-archive-keyring
sudo apt-get update

After rebooting, Volumio no longer serves the web UI, the php5-fpm process runs at high CPU for about 10 seconds when a request comes in, and then returns a 200 OK with an empty response body.

It seems to me like I need to stick with Volumio 1.2 until this repository weirdness gets worked out.

I think that updating the keyring may have started a chain reaction of updating packages, which most of the times breaks the system (volumio relies heavily on custom packages, and setting 2 repos for armv6 and armv7 is not allowed with my repo manager…).
So, try to replicate whitout installing keyring (you don’t really need them).
I will however promise to include mpdscribble in the future.

That would be marvellous as I could not get mpdscribble to install either. Will it be in the next release after 1.41?

try to ADD (don’t remove existing things) this to your sources.list :

deb http://mirrordirector.raspbian.org/raspbian/ jessie main contrib non-free rpi deb http://archive.raspbian.org/raspbian jessie main contrib non-free rpi deb-src http://archive.raspbian.org/raspbian jessie main contrib non-free rpi

Thank you kind sir! That did it, after a massive update and upgrade (took about 30 mins). mpdscribbler then installed without any bother. I made the edits with my last.fm account details and it all works, scrobbling away.


sudo /etc/init.d/mpdscribble status -l
[sudo] password for volumio:
● mpdscribble.service - Last.fm reporting client for mpd
Loaded: loaded (/lib/systemd/system/mpdscribble.service; enabled)
Active: failed (Result: signal) since Sun 2017-12-24 14:50:21 UTC; 10min ago
Docs: man:mpdscribble(1)
Process: 612 ExecStart=/usr/bin/mpdscribble --no-daemon (code=killed, signal=TRAP)
Main PID: 612 (code=killed, signal=TRAP)

Dec 24 14:50:16 volumio systemd[1]: Starting Last.fm reporting client for mpd…
Dec 24 14:50:16 volumio systemd[1]: Started Last.fm reporting client for mpd.
Dec 24 14:50:21 volumio mpdscribble[612]: connected to mpd 0.20.0 at /var/run/mpd/socket
Dec 24 14:50:21 volumio systemd[1]: mpdscribble.service: main process exited, code=killed, status=5/TRAP
Dec 24 14:50:21 volumio systemd[1]: Unit mpdscribble.service entered failed state.
any pointers what could cause this? nothing regarding mpd errors in /var/log/volumio.log either