smb share of Volumio usb disk is readonly

Hi!

I have a 1TB USB disk connected to my Volumio RP3 and I want to load music into this disk by connecting to it as a smb share from my PC. The smb connection to the Volumio shares is ok, but the disk is read-only.
What could be the reason for this?

This is my smb share definition:

directory mask = 0775
create mask = 0775

[DISK]
comment = Volumio USB DISK
path = /mnt/USB/DISK
read only = no
guest ok = yes
public = yes
follow symlinks = yes
wide links = yes

The disk is formatted exfat, and it is writeable from the system, by ssh terminal as the volumio user.
The “mount” command shows this:
/dev/sda1 on /media/DISK type fuseblk (rw,nosuid,nodev,noatime,user_id=0,group_id=0,allow_other,blksize=4096,uhelper=udisks)

The access rights of /mnt/USB/DISK is

drwxr-xr-x 1 root root 131072 Jan 1 1970 DISK

sudo chmod a+w DISK

does absolutely nothing. I suspect I should want

drwxrwxrwx 1 root root 131072 Jan 1 1970 DISK

Why is it not possible to change the access rights of this disk?

I just found that even USB memory sticks inserted to my RP3 are readonly as seen from the smb share point (USB)!

Its also the experience for me. Could this help? askubuntu.com/questions/88108/s … ated-users

I tried that, and it did not work.

However, I got it working by doing two things:

  1. Add a new share, “DISK”, with path to directly to the DISK mountpount;
  2. Set “guest account = root”;

In the default “USB” share, the mounted DISK still shows up as “no access”. Strange.
In the new “DISK” share, I have write access.

[code][global]
netbios name = Volumio
server string = Volumio Audiophile Music Player
workgroup = WORKGROUP
security = user
guest account = root
map to guest = Bad User
encrypt passwords = yes
wins support = yes
local master = no
preferred master = no
domain master = no
os level = 30
usershare allow guests = Yes

directory mask = 0775
create mask = 0775

[Internal Storage]
comment = Volumio Internal Music Folder
path = /data/INTERNAL
read only = no
guest ok = yes

[USB]
comment = Volumio Internal Music Folder
path = /mnt/USB
read only = No
guest ok = Yes
guest only = Yes
create mask = 0777
directory mask = 0777

[NAS]
comment = Volumio Internal Music Folder
path = /mnt/NAS
read only = no
guest ok = yes

[DISK]
comment = Volumio Internal Music Folder
path = /mnt/USB/DISK
read only = no
guest ok = yes
public = yes
follow symlinks = yes
wide links = yes
[/code]

I do not really like it, to have “guest account = root”.
In this case it may not matter so much, but it is still bad practice.
The DISK is mounted as “root” and this may be the reason it is necessary.
I would much prefer to mount the DISK as user e.g. “mpd” and use this user as guest, but I don’t know how to do that in Raspian.
Any suggestions are appreciated.

Some new findings, speaking against my conclusion:

If I plug in ANOTHER usb hard disk, it shows up in the USB share, with rw access. Along with the other disk, which is indicated “no access”. Interesting.

The main difference must be the disk formatting type.

This is /media:
drwxr-xr-x 1 root root 131072 Jan 1 1970 DISK
drwxrwxrwx 1 volumio volumio 4096 Nov 12 09:44 External

DISK is not even readable from the USB share, while External is ok, rw.

root@volumio:/media# mount | grep /dev/sd
/dev/sda1 on /media/External type fuseblk (rw,nosuid,nodev,noatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks)
/dev/sdb1 on /media/DISK type fuseblk (rw,nosuid,nodev,noatime,user_id=0,group_id=0,allow_other,blksize=4096,uhelper=udisks)

fdisk -l shows:
Device Start End Sectors Size Type
/dev/sda1 34 1953507327 1953507294 931.5G Microsoft basic data
Device Boot Start End Sectors Size Id Type
/dev/sdb1 2048 488397167 488395120 232.9G 7 HPFS/NTFS/exFAT

I don’t even know what “Microsoft basic data” is, never seen it before.
Googeling on it indicates it may be ext4, misinterpreted by disk. True?

Anyway, I would really like to get a grip on how the automount is set up.
Maybe there are some options for different disk formats.
Googeling for “Rasbian automount usb” gives a really meager result.
Again, suggestions are appreciated.

I gave up and re-formatted the disk as ext4.
Now the DISK is rw under the Volumio standard USB share.

All is fine, but I am still curious over the limitations and requirements here.
If I disconnect this disk now and connect it to a WinPC, it will not useable, since Windows does not understand ext4.
What disk formats are compatible?

You might like to have a read of this article.. A few years old now, but still useful.

Thanks for this answer. I had the issue that the Music folder on the USB HDD was read-only whereas the root folder of the USB was not. Driving me crazy.

Your reference led me to a crash course into SSH and CHMOD. Logging remotely into volumio (a first time for me) I used CHMOD -R 777 (also a first time) in the root of the USB HDD and can now copy files from win10 into volumio :slight_smile:

One way around this issue is to enable SSH and then connect to Volumio by SFTP.

From Linux sftp://volumio@... (IP address)

From Windows or OSX you can use an FTP topols such as Filezilla configured for SFTP.

Hope this helps

Had the same problem… USB HDD connected to Volumio was RO.

I found out this was due to a faulty NTFS filesystem on the USB HDD. I connected it to Windows PC and did an automatic repair. That solved the problem.