SegFault when loading plugin

I am running volumio with an ES9018k2m DAC. Everything works fine but I now wanted to try hardware supported volume instead of software volume. There is a plugin for this but it just crashes with a segmentation fault and no other info in the log.
I tried to find out what the problem is but my linux and javascript skills are somewhat limited.
Here are my questions:
How can I run the plugin from the shell instead of the web-gui? And how do I get more info on where the seg-fault happens? Basically I am looking for a way to debug the plugin, it may b e a minor problem as the plugin seems to work for some people and unfortunately I could not get any support from the author.
The source code can be found here:

finally figured it out using console.log() at every important line of the script.

It turns out the segmentation fault happens if the script tries to access the I2C bus without getting a proper response from the device (actually was a wiring problem) which seems to me someone did a bad job down at the low level driver… it should lead to a timeout and not a segmentation fault if the hardware has a fault.