Rpi 3 WiFi hotspot issues...

I’ve been battling this problem for days. I’m building two Volumio “music boxes” for my daughters, for Christmas, and time is running out to get this system stable. I’m using RPI 3’s with HiFi Berry DAC + Pros, and attached 1TB Seagate laptop drives, connected to USB ports via USB to SATA cable. The latest build of Volumio 2 (from last week or so).

For user interface, I’m using Samsung Galaxy Tab A 7" tablets. Tried the Pi touchscreen, and it was very slow, and the backlight doesn’t shut off, etc. I didn’t think it was that good. For an extra 30.00, the girls will have a tablet that becomes a handheld remote, and has other uses, so…

Power is from a 3A NorthPada power supply. The power supply seems adequate, and I’ve added extra filtering to clean it up.

At this time I just want to use the WiFi hotspot to connect to Volumio. Reason is one daughter is living in a dorm at college, and the WiFi situation is unknown to me. My other daughter is 1000 miles away, and is moving into a new apartment soon, and again I don’t know what she’s going to have for WiFi at the moment. So having the access point as primary connection, is my goal at the moment.

What happens is the built in WiFi on the Pi seems to turn on and off. I’m wondering if there is a setting that can be changed to keep the WiFi always on? I’m not sure what is causing this. Both Pi 3’s have shown this symptom. I have been using an android app called WiFi Analyzer to monitor the signal level from the Pi access point. Sometimes it works flawlessly. Re-boot, and now it’s on - off, power level going up, and down.

Is the built in WiFi junk? Are there driver issues? Is the Edimax a better way to go, and if so, do I need to disable the built in WiFi?

The latest thing I have tried is an Edimax USB WiFi adapter, which seems to be working. But I have had the built in WiFi work for hours, then unplug the Pi, and move it to a different spot, and it goes intermittent. I have a ton of time and money into this project, and wood working, etc. I just want it to work! But I’m running out of ideas!

Help Please!

Hmm I have read about issues with a power save mode on the raspberry Pi 3. Here’s a video about it:


Tonight, I put Edimax USB WiFi adapters in both systems. I’ve been playing them both, and turning them on and off. And so far, all is good. Now I just have to figure out how to turn the gain down in the config file. The sound is distorting no matter how low I turn the Volumio volume (say 60%) then turn my preamp up, still sounds a bit distorted.

I think the WiFi problem might be solved, just sucks to have to add a USB dongle to a Pi that has WiFi… Not 100% sure yet…

Dear Mike,
from my experience, the pi3’s integrated wifi is not sufficient at all for a 100% stable usage: if your area is congested of wireless networks, if you’re not really close to the access point or if you enclose the pi a little, the integrated antenna will not work properly.
The best experience comes from using the edimax nano dongle, which seems to be the sweet spot beetween driver integration and hardware capabilities.

That being said, since you’ve already solved it, let’s talk about the volume, try to change the mixer control from the volume settings.
Let me know if that helps

Mike, you were right: the power saving off function, seems not to apply to pi’s integrated wifi. So here’s how you can disable it, I think this will greatly improve its performances

Edit the wireless daemon systemd service

sudo nano /lib/systemd/system wireless.service

and add:

ExecStartPre=-/sbin/iw dev wlan0 set power_save off

so it will become

Description=Wireless Services

ExecStartPre=-/sbin/iw dev wlan0 set power_save off
ExecStart=/volumio/axiom/wireless.js start
ExecStopPost=/volumio/axiom/wireless.js stop

Let me know how that works

Thanks Michelangelo!

I went to bed just a few minutes before your reply! Sorry I missed you! But, last night, I left one system running, and unplugged the other. The one that I unplugged, when I powered it up this morning, decided to choose the built in WiFi, and the Edimax was not running, no LED. So WiFi was acting badly, and I couldn’t get the AP UI. I rebooted again, and this time, it did choose the Edimax.

I think the internal Wifi might be OK, if I can get the power management disabled. I will try that later today. Are your instructions to disable the power management for the built in wifi?

Or, is this to disable the internal WiF,i and only use the Edimax WiFi?

And back to the sound quality:

This morning, I discovered there are a TON of options for the sound settings on the HifiBerry! I will have to figure these out. All I know is, a few weeks ago, I did a listening test between my Buffalo DAC and the Hifiberry, and the HiFiBerry was sounding really really good! Not as good as the Buffalo, but damn close! I am listening thru 8ft tall Acoustat 2+2 electrostatics, powered by highly modified Acoustat direct drive servo tube amplifiers. The system has very high resolution!

Thank You Very Much!

Will keep you posted!


Hi Michelangelo,

My wireless.service file was slightly different than what you posted. It had a line saying Type=forking and mine did not have the Remainafterexit=true

Anyway, I tried adding just what you suggested, saw no change. So next, I replaced my file with what yours looked like. Neither one seemed to make any changes.

So, how about just a way to kill the onboard WiFi and use the Edimax USB unit? Interestingly, while experimenting with this Pi, I found that it was about 50-50 as to which WiFi adapter it chose. Even with the Edimax plugged in at power up, sometimes it would use the on board, other times it would activate the Edimax!

I’d just like to kill the built in WiFi and be done! :wink:

Thank You!