RP3+Mamboberry LS DAC UI lost

I searched the forum thorougly before i send this message.
My system is RP3, Mamboberry LS DAC+ and a USB 2.5 inch hdd (1A).
Latest version of volumio is the OS of the device.
DAC is supplied with a 5V 5A linear power adapter. RP is seperately powered with original 2.5A switched adapter of RP3.
I have a serious problem. Everything starts ok, but after a while (time is not constant), i lose user interface, so i can not command RP. I tried many different power combinations, only linear, linear with switced, only switched so on, with no success.
I tried volumio and runeaudio as OS of the system. I have the same problem both for both OS.
5A linear and 2.5 A switched adapter power must be more than sufficient for this system. So i don’t think power is the problem. Still, I tried to remove usb hdd from the system and listened to web radios and spotify. Same problem is there. I loose UI. Only way to get connected to system is a reboot after the UI is lost. I have to power off while the system works and on on again. It may cause a serious problem i guess, but i have nothing else to stop RP playing…
When i lose user interface, i use net analyzer app in my iphone and i can see ip number of the RP. But there is no UI. I am sure that RP+DAC is connected to my home wifi because, if i listen to web radio or spotify, i can keep on listening to radio. So, system is definetaley connected to wifi but, there is no way to get connected to RP by user interface or iOS app.
I googled for the issue. There are some advices for the problem. I followed them and changed config (sudo nano /etc/modprobe.d/8192cu.conf) to cancel power saving:
options 8192cu rtw_power_mgnt=0 rtw_enusbss=1 rtw_ips_mode=1
options 8192cu rtw_power_mgnt=0 rtw_enusbss=0 rtw_ips_mode=0
Problem is still there…
Any advice?

This sounds like a hardware problem. Do you have a usb wifi dongle to try in place of the RPi3 internal wifi? If not, and you can ssh in when you lose the UI, what does ‘ifconfig’ and ‘sudo iwconfig’ show?

Edit: Have you had a working system with this DAC and Volumio previously?

No, I don’t have a usb wifi dongle. And unfortunately, i can not ssh in when i lose UI. I can not get any communication with the RP. Neither UI nor ssh. But RP is connected to home wifi because RP keeps on playing internet radios and also net analyzer shows it’s ip. But when i try to ssh in that ip, i can not.
Very strange problem…
And , no. I have just bought this DAC.

Connect the RPi directly to a monitor and keyboard?