Router USB address

I already know that I’m the World’s biggest idiot, but for the life of me I can’t figure out how to add the USB drive plugged in to my router as a Volumio Network Drive. Can someone please walk me through the set-up?

I can see and access the USB drive easily from Ubuntu’s Nautilus file browser. Which lists the address of the folder I wish to add as: smb://rtrusb/volume(sda1/music

[The LAN address is]

When adding a new drive: I give the drive a name; enter the address, set the path; select CIFS; add the username & password; save…

Then nothing.

I’ve tried every combination of address and path I can think of but still nothing happens.

Help would be much appreciated.

Thanks for your time.


Have you tried adding as a cifs share, address=, path=rtrusb/volume(sda1)/music ?

I’ve tried that. On its own and prefixed with smb, http. I’ve also tried disabling and enabling authentication.

I should mention that the scan lists the usb alongside the other network devices. It even has the volume listed in the drop-down. Clicking this fills in the details. But this doesn’t work either. I just don’t get it. It works perfectly with both my PC’s file browser and with Kodi: openelec & libreelec.

If you have ssh or direct access to your Volumio device, then you could try manually mounting the NAS share … this will probably give give you some error information to go on.

sudo mount -v -t cifs // /mnt/temp

Can you also report the results of the following please:

smbclient -L

The manual mount gives me this: -bash: syntax error near unexpected token `(’

The smbclient provides this report:

Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.0.14a]
Server requested LANMAN password (share-level security) but ‘client lanman auth = no’ or ‘client ntlmv2 auth = yes’
tree connect failed: NT_STATUS_ACCESS_DENIED

                                                                                     - - - - - - - - - - - - 

Thank you for your help, but please don’t spend too much time trying to figure this out: unless you think it’s an important issue. I’ve decided to get a new NAS instead. Though a good deal cheaper, a usb drive plugged in to a router isn’t a reliable alternative to a proper network drive.

Well, your manual mount suggests that it is not happy with the brackets (I did wonder about those). Try surrounding the path with single quotes (’).

Also, just try ‘music’ as your path.

No, it’s not important, but it’s annoying :wink: