root Login Problem over SSH

Hello,

For my first Raspberry Pi Project, i Installed today Volumio on my Raspberry Pi 3.
VERSION: 0.976
RELEASE DATE: 28-07-2016

The access over SSH (with Putty) with username:volumio works fine.

But with the root user i always get “Access denied”.

No changes have yet been made on the System.
The Board Search has not helped me.

Thx & Greetings from Germany
PeX

Ok, I find it.
In the sshd_config
was

permitrootlogin no

I change it to

permitrootlogin yes

and

service ssh restart

now it Works :slight_smile:

But good to know, that its default on no.

cheers

just to know, why do you need a root access ? Using SUDO should be enough. Or can you explain ?

I dont need it directly.
But i use a Tutorial to install the Spotify Connect into Volumio. In this Tutorial, there use/need the root User to Copy the files via WinSCP in the folder.

I 've got a suggestion for you, I started to write a plugin for Spotify connect, you can test it here: https://github.com/balbuze/volumio-plugins/tree/master/plugins/music_service/volspotconnect. You need a app key. Download the zip file and install it through the UI. Let me know…
edit : installation is a bit long and you have to be select English as language to access settings. And it may NOT work…

Hey Thx. I will check it :slight_smile:
At this time i used a Tutorial from the German Page PowerPi.
powerpi.de/spotify-connect-auf-d … bedienung/

After first Test it looks good. But i think i need the HiFiBerry for a better sound.

Instead of allowing root login via the network, best practice would be to just have you login as volumio and run:

sudo su

to become root and keep a session open as the root user.

or:

sudo -i

will give you the same result.