Reducing noisy PSU interference

This isn’t really a Volumio issue so may not belong here. Apologies if so.

As I’ve posted about in another thread I’m trying to run Volumio x86 on a Minix z64.

So far, pretty good though I haven’t been able to install to the hard drive and the built in wifi doesn’t work. However, booting from a USB and using a USB wifi dongle is working ok.

The major issue now is a low level hum/hiss that seems to be caused by the PSU or the device itself. The noise is audible across all channels of my Yamaha amp (not just the USB DAC channel it’s connected to). The noise doesn’t increase in volume even if I turn my amp up full.

I picked up an Audioquest jitterbug, thinking that the issue was with the USB output at first, but this hasn’t solved it. The noise isn’t present when connected to my Macbook or NUC. I’ve connected the plug to a couple of outlets with the same result and I’ve tried a few USB cables (though they’re all cheap ones - the kind you get free when you buy a printer, but they look of ok quality).

What are my options here? Would a power strip conditioner like this one ( … onditioner) be worth a look? Or do I need to spend a little bit on a better USB cable? Or is this just the nature of these cheap devices?

The noise is almost ignorable, certainly less than I get from my turntable cranked up but ultimately it’s going to mean running Volumio on the Minix is a no go if I can’t fix it. Maybe it is time to bite the bullet and buy a MINI86.

hm… if I understand correctly you only have 2 points where your Minix device has a connection to the rest of your system, so I would start there:

  1. Maybe look at something as the Sbooster vbus2 isolator ( which cuts the powerlines of the USB feed.
  2. Use a different powersocket, preferably from a different powergroup to power the Mimix

Finally, if the hum is not coming through the connection points, it could be interference. So move the machine as far away as possible from any cables and devices.

Hopefully one- or the combination of things solves your issue. Keep us posted…

Thanks for the tips. I’ve just tried unplugging everything from my amp and the power but still get the same results. There may have been some improvement when powering it from an outlet across the room but I’m not certain, and that wouldn’t be a solution anyway thanks to the position of it.

There’s someone selling a Vbus for £10 on eBay so I’ve ordered it. I’m not totally sure it will solve anything that the jitterbug won’t though. I’ll report back when it arrives.