raspi 3 with HifiBerry DAC + light (failed to open alsa)

alsa message.jpgHi folks,
I am running volumio (2.389) on a raspberry pi 3 with an HifiBerry DAC + light.
When i use the normal Audio Jack as output volumino functions well, but when i choose HifiBerry DAC Plus as output i get these error messages and no sound-output:
Error
Failed to open “alsa” [alsa]; Failed to open ALSA device “hw:1,0”: No such file or directory
Error
Failed to open “alsa” [alsa]; Failed to open ALSA device “hw:1,0”: No such file or directory

I checked this forum for help and tried
“disable i2s dac, reboot, enable i2s dac again”
This did not help.

Output from aplay -l
volumio@volumio:~$ aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
Subdevices: 7/7
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
Subdevice #4: subdevice #4
Subdevice #5: subdevice #5
Subdevice #6: subdevice #6
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0

Any suggestions for help?
All best
Daneben

Your DAC is not listed with aplay. Have you rebooted after setting the DAC in volumio?

Yes, I have done that (several times).
:
:
The HifiBerry DAC Plus wont show in aplay -l.

In the meantime i switched the settings from HifiBerry DAC Plus to HifiBerry DAC.
Now the audiooutput works correct. This is rather strange cause i definitively have a HifiBerry DAC PLUS (light).
Now apay -l looks like this:
aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
Subdevices: 7/7
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
Subdevice #4: subdevice #4
Subdevice #5: subdevice #5
Subdevice #6: subdevice #6
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: sndrpihifiberry [snd_rpi_hifiberry_dac], device 0: HifiBerry DAC HiFi pcm5102a-hifi-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0

Is there a difference in soundquality when I use the “wrong” driver? Or is there something wrong with the HifiBerry DAC Plus - Driver?

All best
Daneben

All best
Daneben

Hi Daneben,

Your DAC+ light is based on an ES9023 chip which doesn’t have hardware mixer control.
Choose “Generic DAC” or “HiFiBerryDAC” (without the plus).

Good luck
Josef

Hi Josef,
thanks for clarification. Volumio functions well now and I am very satisfied with the sound quality!
Thanks for help! :mrgreen:
all best
Daneben

I have the same problem. I connected the HifiBerry DAC + light to my Raspi 3+, selected the HifiBerry DAC at the volumio config, but I do not get eny audio output. When I start playback, it looks fine on the UI, the output of aplay -l looks fine and the dtoverlay entry is set at the config.txt.

Any more ideas what I can do? Are there any packages I might have to install manually?

Solved it. Problem was that I had activated the IO plugin and it has blocked one of the GPIO ports Hifiberry needs.

I have a very similar ploblem. Please look at my post: raspberry-with-hifiberry-dac-pro-problems-t11884.html

Just bought one of these, managed to get it working by selecting “HifiBerry DAC” in the audio output option.

Forgive me for the noob question but does the lack of hardware mixer control mean that its not possible to control the volume from within Volumio at all?

Thanks

you have to select ‘software’ volume mixer to do that :wink:

Excellent! Works great, thanks :smiley:

Takes about a second to change the volume when I select the level, I can live with this but is there an option I can select to speed this up slightly? Using a DAC+ Light with pi Zero.

Cheers.