Raspberry Pi3 + Wifi + Volumio

Before anybody tells me to “just search the forums or google”, I tried that, the forum’s google said that my searches were “too common”, yet, my question is not addressed in the FAQ. I literally could not search for my problem…


I’m sure it is something simple I am overlooking, but I have come across two issues.

  1. After purchasing a new RPI3, I’ve connected via LAN, done initial setup, connected to LAN via wifi. After rebooting without my LAN cable plugged in, the PI isn’t connecting to the network wirelessly. Is there something I am missing. I found a post somewhere specifying to do exactly what I have done, yet no joy…

  2. Is there a tutorial / guide for multi-machine / multi-room set ups? I have two PIs in the house, and I would Ideally like to be able to connect to each machines webUI through different .local address. I’ve specified unique host names for each, but can’t connect via hostname.local. Further, when both PIs are running, going to volumio.local boots me to a UI view with a “multi-room” view along the bottom of the window. However, whenever I click on the remote (I presume) machine, I just getting a spinning wheel animation that runs forever.

Thanks in advance for help! Great product - all the hard work is appreciated!

It would be useful to specify what version of Volumio you are using, and specifically state what changes you have made to the defaults eg, are you trying to set up a static IP address rather than use the default automatic IP.

We are solving the bug of the spinning wheel when clicking on the Multiroom tab, also the no wifi-without-lan is a bug that we’re solving…
Hopefully end of this week all your problems will be solved


I am running the current distro offered via the download link on this site. I haven’t changed anything other than the host names.

Thank you, I will look forward to those fixes!

Is it possible to connect to individual units via distinct host names? So for example, box1.local , and/or box2.local?

Your name.local mileage depends on whether your network and connected devices successfully use zeroconf (Bonjour) services. It doesn’t work for me using android phones and a Linux PC. I used to use static IP addresses (assigned by Volumio) for my several RPi, but this has become problematic in Volumio 2. Now, I leave the default automatic IP address in Volumio’s network settings, and get my router to assign a static IP address to each Volumio device.

Right, well - volumio.local seems to work just fine. Is changing the hostname setting supposed to affect this address?

Yes, volumio.local should map to the actual IP address of the device, where volumio is the hostname of the device.

in my case, pinging the device with its name results in:

[code]sudo ping volumiokitchen.local

PING volumiokitchen.local ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=64 time=0.106 ms
64 bytes from icmp_seq=2 ttl=64 time=0.084 ms
64 bytes from icmp_seq=3 ttl=64 time=0.083 ms
64 bytes from icmp_seq=4 ttl=64 time=0.079 ms

showing that the device with hostname volumiokitchen is connected, and is using IP address

Yah, see I can connect via volumio.local, but if I change the host name via settings to, say, “derp”, I cannot connect via “derp.local” as I would think I could.

I’m guessing that once the multi room bugs are fixed, I’ll be able to control the individual boxes through the same UI, so… whatever, I’m just not sure what the intended functionality is.

Are you able to ping the hostname without the .local appendage? eg. ping volumio and ping volumio.local should illicit responses from your Pi, and return the same IP address, if zeroconfig is working properly.

I have no zeroconfig but can ping my Pi and ssh without issue.

Ping ‘derp’ and see what you get. Or type http:// derp / (no spaces) and you should hit it just fine.

[code]C:\Users\Ubernode>ping volumio.local
Ping request could not find host volumio.local. Please check the name and try again.

C:\Users\Ubernode>ping volumio

Pinging volumio [..211.87] with 32 bytes of data:
Reply from ..211.87: bytes=32 time<1ms TTL=64
Reply from ..211.87: bytes=32 time<1ms TTL=64
Reply from ..211.87: bytes=32 time<1ms TTL=64
Reply from ..211.87: bytes=32 time<1ms TTL=64

Ping statistics for
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 0ms, Average = 0ms

Pardon if I’m out of line. Subscribing anyways. :smiley: