Raspberry pi Zero governor issue

Hi, and Happy new Year to everyone.

I have installed volumio 2.041 on a raspberry zero, with a wifi dongle and a pimoroni phat dac. I have discovered that it runs with “powersave” governor.
I tried different power supplies, and also a clean install of volumio, but it always defaults to powersave.

Is this by design or a bug with volumio?

what is the disadvantage?

Not sure, but since the pi0 is weaker than the other Pi’s , running in lower clocks might be not optimal.
Plus I want to use transmission for torrents, so I could use all the horsepower I can get.

Mainly wanted to hear from the developers if powersave is an intentional choice by them for volumio.

Yes cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor reports powersave too.

You may want to look into this.

Haven’t checked with Jessie Lite if different.
There seem to be some dhcpcd related issue…

You may want to install raspi-config to check/set some settings (but to do so you need to mimic some changes pushed yesterday)
Interested in your discoveries.

Good, so that means that it’s not my hardware only.

I have checked with raspbian jessie lite, and the governor successfully changes to ondemand while booting. (with the same rp0+phat dac+wifi dongle combination)

What i have discovered in raspbian is that if there is some config trouble at boot, like wanting to mount a network share before connecting to the network, then it causes the governor to stay at powersave.

That’s why i posted here, to discover if it is a bug (like i said it happens in clean volumio install too) or if it is intentional by the developers for compatibility or some other reason.

I think we can add a script that sets the governor to ondemand or performance…

That would work.
What do you suggest, rc.local ?

If you remove force_turbo=1 from config.txt then governor is on ondemand after boot. (tested on my Pizero/Volumio)

Interesting reading here and related references.

Note: making this change will be overruled by a change in DAC settings! Indeed DAC settings changes my alter config.txt in a rather radical way.
(i2s_dacs/index.js should apply changes with sed-like search/replace rather than rewriting config.txt as a whole)

Unfortunately this didn’t work for me. I’ll have to look into it when i have more time available, so i can try a fresh install and remove other variables from the situation.

Maybe it’s because I installed raspi-config:

volumio raspi-config[236]: Checking if shift key is held down:Error opening '/dev/input/event*': No such file or directory volumio raspi-config[236]: No. Switching to ondemand scaling governor.