Random Touch screen trouble

I have been moving right along with Volumio, but had random glitches here and there. Like, the Pandora app would start flashing random album art and titles like flash cards. Song sounded good, but volumio was having a seizure.

So, I flashed it and started over. I installed everything the same about 8 times now and I can’t get the touch screen to work. It looks good, but when I rotate the screen 90, I get an “Unable to connect to Xserver.”

Any ideas?

Please provide some more information:

What is the version of Volumio and the Touch Display plugin?
Did rotation work before?
Are you using a Raspberry Pi (if not: what other board)?
What is the exact brand and model of your screen?
Did you install other software or change files manually related to the screen? If so, please describe what has been installed.

Ver: 2.806 - current download.
Rotation worked great before.
Raspberry Pi 4
UCTRONICS 5" Touch UC-586


  1. Install Touch Screen Plugin

  2. wget https://raw.githubusercontent.com/UCTRONICS/UCTRONICS_HDMI_CTS/master/uc586/hdmi_480x800_cfg.sh

  3. sudo chmod +x hdmi_480x800_cfg.sh

  4. sudo ./hdmi_480x800_cfg.sh

  5. sudo echo “display_rotate=1” >> /boot/config.txt

There is a conflict somewhere. I’m sure it’s right in front of my face. : )

Thanks for your help!

Thanks for reporting back.

Please additionally post the results of
ls -al /tmp/.X11-unix
systemctl status -l volumio-kiosk.service
cat /boot/config.txt

In the first post you said you get the error if/when you rotate the screen by 90 deg. Does this mean the error does not occur with other rotation settings (0, 180, 270 deg.)? Also, in what situation(s) does the error message appear?

BTW I think you could remove display_rotate=1 from /boot/config.txt and use the rotation option of the plugin though I do not expect this to solve your issue.

Thank you for your help with this! So… The screen info said, “It requires 3 connections. USB Power, USB Touch, & HDMI.”

So… That’s what I did : ) Anyway, I un-plugged the POWER USB… Now, the screen works and can be rotated.

This is a Power problem. The Pi is running on a usb-c power adapter specifically for the Pi. I’m not sure I have it right : )

Do you have any suggestions?


Looks like that :wink:

When I glanced over the picture of the PCB on the manufacturers page I saw one of the USB connectors “labeled” “Micro USB (Power & USB Touch)” and my first impression was: you can use just this one to power the screen as long as the power delivered from the Pi is sufficient. Since the user guide also contains the note

  1. The USB touch port also takes power input, so you can try to power the display and add touchscreen support with a single cable.

I consider the info that 3 connections are required to be a bit misleading. A connection to “Power Only” would only be required if the power from the “Power & USB Touch” connector should not suffice. But in the case where a dedicated power supply is not necessary connecting one to “Power Only” should not lead to the issue you had experienced… that’s weird.

Long story short: I would think your connections are correct now. Just make sure your power adapter (connected to the Pi) is strong enough to supply all devices (Pi, screen, possibly USB disk…) properly.

I am trying to hone in on this issue. : )

Plugging the power to the screen and unplugging it is getting results. But now it is obvious…

If I boot the raspberry pi with the screen connected, it will not connect to Wi-Fi

If I boot the raspberry pi with no screen attached, I get Wi-Fi.

I just checked my router, and it is not logging in if the screen is plugged in. : /

i know that old rpi’s share connections… it could be that you have that problem…


I thought it was a hardware problem too. But this is my second Pi-4 and I’m having the same trouble. In fact, the Moode Player works great on this setup. It just doesn’t have any features, or look good. : )

I’d prefer to get Volumio working. My standards of “working” are also dropping. Don’t even need touch anymore. Just something on the screen haha.

rpi 4 doesn’t have that (shared) problem any more that is what i’m reading… soon i will be testing rpi 4 again with volumio and pihole in one
first have to install 32bit volumio then update and upgrade to 64bit after getting all of volumio incl. youtube plugin i gonna bash pihole next to it.
i’m using the standaard pi 7inch screen and don’t have that problem

It could be that the system is demanding too much power during the boot process.

Maybe try with a PC monitor or TV which has their own power supply. If WiFi should work in that configuration you may boot without any monitor. Then connect the UCTRONICS touchscreen not until booting Volumio has finished.

You you could also execute dmesg | grep voltage to check for “under-voltage” warnings.

With a name like gvolt, I’ll take your word when it come to power. : ) I need to check the grep for under voltage. I’ll research how to do that! Thanks for your help!

:grin: .

Just use the command from my previous post. An under-voltage warning would then look like Under-voltage detected! (0x00050005).

Did you already test if the problem also occurs without the UC-586 but with a TV or another HDMI monitor?

BTW: Independently from your WiFi issue I would recommend to write the following settings (given by “hdmi_480x800_cfg.sh” you linked above) to /boot/userconfig.txt instead of /boot/config.txt:

hdmi_cvt 1024 600 60 6 0 0 0

This has the advantage that these entries remain untouched when Volumio gets updated. In contrast /boot/config.txt file gets overwritten on each Volumio update (further information) and you would have to edit /boot/config.txt again.

Since max_usb_current=1 and hdmi_force_hotplug=1 are already part of the “standard” /boot/config.txt there is no need to add them to userconfig.txt.


We are getting some where! : ) But I’m only picking up about 1/2 of what you’re telling. : ) But it’s working!

My problem might have been: I was using the overscan commands. But, when I add them now, I am getting the X-sever error. And, I turn off wifi, and ran a ethernet : )


I have a 5" display, but 4.7" is viewable. That’s my next challenge.

Thank you for all your help!

Sorry about that. Feel free to ask.

So the error still disappears / (re)appears in dependence of omitting / using the overscan commands?

P.S. Did you have the chance to test with another HDMI display (TV, PC monitor) in the meanwhile?


… So, I added your commands… And everything was working great! I changed the cvt=1024 to 600. It was a little small.

Then I added only the overscan left=24 … Did a reboot, and it worked! Then I changed the overscan left=30 and added an overscan bottom=12 and… now it will not Boot at all : )Even with the display unplugged.

I will try another monitor tonight. But right now, I need to figure out how to change the userconfig.txt back!

If you keep helping, I’ll have to stat paying you. : )

If Volumio doesn’t boot you will probably need to remove the SD card and edit userconfig.txt from a PC where you can mount and access the boot partition (most easily on a system running Linux, I guess).

@gvolt gvolt mounting and editing on windows ? not to do… read only … or other ways will corrupt the files…
best way is to make a usb with linux live on it .bootable usb and boot from that …
i guess didn’t try that but i think that’s the way…

I would not say it is impossible but as I don’t use Windows frequently anymore so I cannot give any advice in this regard.

i was looking for a way on windows … but still didn’t find it …some can edit but in the end it could corrupt your files read many things tested a lot to…i’m a windows based guy and could not find a way to do it.
so if any know a way on windows… please inform me about it …