Problem to install Volumio on PC (x86)

I’d like to install Volumio on a my PC but I have difficult to perform the boot using the image downloaded from Volumio website. I tried to flash it using Balena Etcher but the PC doesn’t see the usb key as bootable. Furthermore I tried also to mount directly the .img file on Win10 thinking to boot it via Virtualbox but Windows says me that The image file is corrupted, I’ve also tried to download it again with the same result.

Please could you help me to solve?

Thank you so much,

booting from usb is set in the bios boot options… and pick boot from usb stick.
mounting doesn’t work because it schould boot from the stick and img is not corrupt

Thanks dvo, the problem is that usb stick there isn’t in the list option, I see only CD, network and hdd :thinking:

did you put it in before you boot? normaly it should show up…
i would try other usb stick and did you burn the image with baleno etcher?

Yes to all, flashed by balena etcher and tried also another usb stick. The curious thing is that if I try to mount the .img on Win10 the system says that the file is damaged.

it doesn’t work with a mount the img got 3 partitions instead of a normal img of 1 partition…
1 boot fat32 and 2 ext4 and the ext4 is not used on windows.
does your usb stick got recognised in your bios? normaly it should show up.
but there are still some systems that doesn’t support that option…
switching port some times could help.

Thanks, you are very nice, this afternoon I will do some other test and then will let you know.

I have encountered similar issue earlier. I used Rufus to burn the image. Worked well.

Thanks artsky, using Rufus works fine!

Now, I have booted Volumio correctly but when I click on Install to disk to move Volumio on hdd, I have this error: Cannot prepare system for resize.

Have you some idea?

i can think of a few
it could be that the disk your copying to …maybe there is already something on that drive…

Nothing to do :frowning:, I have formatted the local hdd (a disk m.2 500GB) using Fat32 file system using an Ubuntu Boot Live but when try to install on the disk I have the error: Installation on the disk failed: Cannot prepare system for resize.

Have I to abbandon the idea to use Volumio on the pc? :sob:

i would say go to the x86 part on the forum maybe they still have a ace in there sleve

I understand the problem, Volumio is not compatible with m.2 disk, during the week I’ll try with a hdd sata. For now thanks to all, I’ll keep you informed.


Just take the latest Volumio 3 beta for x86, it will also boot from nvme (m2) and the install to disk (incl. emmc, ssd, nvme, hdd) is a lot, lot faster and without errors.
Functionality is nearly as good as Volumio 2, just some cosmetic differences left to iron out.

Thanks @gkkpch , please could you let me have the right link?

Go to the development section, Volumio beta for x86.
Please read the first post, for two reasons:

  • it shows the download link to the latest version.
  • it shows what we expect from you in case you need help

IT WORKS FINEEEEEEEEEEEE!!! I used the version 3 suggested by @gkkpch

Thank you so much guys!