Problem display 3,5 480x320 SPI


I boght new display from waveshare 3,5 LCD B. it connected via gpio and backlight is working.
but, nothing more. I tried to install drivers from github a lot of time, but still same result.

the system felt down and by next boot some where stoped. for was neccessery reinstall system again.

I would like to ask if has sombody the same experiences and some solution.


I suggest to start with a fresh Volumio version (BTW: What is your Volumio version?).

Then nstall the Touch Display plugin from the plugin store.

Don’t run the install script from Waveshare. You will have to do some adjustments to /boot/userconfig.txt and maybe some other files, too. We can do this step by step.

What is necessary depends on the model of your display.

Do you have revison 2 of the display?

I have RPI 3B v2, display is rev2, and volumio is from today.

Assuming you are starting with a fresh Volumio system:

  1. Install the Touch Display plugin.

  2. Download the display specific overlay:


  1. Copy the overlay to “/boot/overlays/waveshare35b-v2.dtbo”:

sudo cp waveshare35b-v2.dtb /boot/overlays/waveshare35b-v2.dtbo

  1. Open “/boot/userconfig.txt”:

nano /boot/userconfig.txt

  1. Add the following lines:
  1. Save “/boot/userconfig.txt” by typing Ctrl+x then y and Enter.

  2. Download “99-calibration.conf-35b” as it might be necessary to calibrate the screen:


  1. Create “/etc/X11/xorg.conf.d” in case it’s missing and copy “99-calibration.conf-35b” to “/etc/X11/xorg.conf.d/99-calibration.conf”:

sudo mkdir -p /etc/X11/xorg.conf.d
sudo cp 99-calibration.conf-35b /etc/X11/xorg.conf.d/99-calibration.conf

  1. Open “/usr/share/X11/xorg.conf.d/99-fbturbo.conf” with

sudo nano /usr/share/X11/xorg.conf.d/99-fbturbo.conf

and change

Option "fbdev" "/dev/fb0"


Option "fbdev" "/dev/fb1"

Save the file hitting Ctrl-x, y and Enter.

  1. For touch function you probably need to install “xserver-xorg-input-evdev” running

sudo apt-get install xserver-xorg-input-evdev

and then execute

sudo cp /usr/share/X11/xorg.conf.d/10-evdev.conf /usr/share/X11/xorg.conf.d/45-evdev.conf

  1. After all that reboot.

Check if touch works and if display and touch orientation are aligned and report back.

dear gvolt,

you are the best!

the display is working very nice.

have nice evening,

1 Like