[PLUGIN] YouTube2

hehe moving forward :slight_smile:

i tried to edit it so i dont write a lot haha
to our thread youtube worked on 2.853 but needs mpd to be updated.
3.10 works just fine without doing anything.

:star_struck: :innocent: :laughing: :rofl: :joy: :upside_down_face: :heart_eyes:
Many many many thx!!!
I followed the instructions on github, entered the few commands given there and it instantly it plays again :slight_smile:
In fact I do have the 2/3 cut off issue, but also I haven’t updated my MPD, so first I will have a closer look on how this works … and then report accordingly.
Great community and great work patrickkfkan!

ah, question related to this: What’s easier, to update to Volumio 3 or to update MPD? And: How to get Volumio 3? I have set my Volumio to Test Mode, but only get the version 2.857 :thinking:

@Axel look up you will find a beta 3.10 if you need one :slight_smile: but if you have the need of a keyboard on screen
it has none it’s the question what do you have (hardware) and what do you want to install…
all by hand store is down…

If you are already on 2.857, then you could try updating MPD first. 3.010 is still beta and while the plugin will work without needing to update MPD, you may find other functions broken like DLNA.

It’s actually not that hard to update MPD on 2.857. Just follow the instructions I gave in that thread.



with the mpd update that would be something from the past … @queengab only if you keep the 0.20.18
you will have problems so update thempd and your good…dir will be : home/volumio/

Can’t understand…please be more clear.

Anyway @patrickkfkan i report my experience.
Volumio latest version 2.853 on arm device (raspi2)
Updated mpd daemon and enabled (MPD 0.21.16 for Volumio (arm, armv7 and x86))
Installed youtube plugin 2 and enabled youtube api method. Works like a charm!!!
Thank you very much. This is a great work for the community.


OT: i thinked the MPD update also resolved my problem with UPNB and bubble upnp client and dlna server but they cotinue not working


What issues do you have with DLNA / Upnp ? Does Volumio ‘see’ the DLNA server at all?

I @patrickkfkan,

thanks for your attention. I wouldn’t like to be OT anyway…
If i try to use volumio as a render dlna or upnp with bullbeupnp or streamwhatyouhear i can’t see volumio on the server list.
In the future i’d like to use myhi-fi also to stream audio from my smart tv… and find a solution.

This was my post some days ago: Bubble UPnp can't find volumio on my local network

Anyway thanks!

Ps: Also search works better than previous plugin. I encoutered problems with smartphone interface and it seems to be over.

hi all again :slight_smile:

i think i am seing a little bug need confermation when adding a new SECTION. i fill in the form then say ADD. after that it is added but all the fields are empty when i change them again and say update it is working ?? any having the same *LITTLE problem ??


balbuze has released touch display 1.2.2 this works great and if you run it on the 3.10beta,
it even restores the store (side effect of the install ) it’s in the store right now… works for both 2.xx and 3.xx

@patrickkfkan if your there check mail of volumio

hey guys,
who is on the 3.10 or 3.14 there is a bug found in the plugin …
we want u to test it if your version got the same problem .
after creating a playlist try to play the queue … if you got the same problem please say it …
what you encounter while trying to play it…

@DoNaLdDuck @queengab @Axel @giorgosperi @tekdrumio
please post volumio version and if you have the same problem…


I can confirm your findings, but I can also confirm that when you fill in the Add Section form and click Add, the data does get saved correctly. You don’t have to ‘Update’ the section - you can just reload the plugin settings page and the correct information will show up.

In the end, I found that Volumio’s ‘pushUiConfig’ is the culprit. I do not know if it is a bug or they designed it to be that way. What happens is that when you broadcast a ‘pushUiConfig’ message (which tells the UI to reload the config page), sections that have been added will appear (and those removed will disappear), but the data that is used to populate the sections will also be messed up. It seems that pushUiConfig is good only when the config sections do not change. If you add or remove a section, then you must call reloadUi() instead of ‘pushUiConfig’.

I have updated the plugin accordingly, so now when you add or remove a section, the plugin settings page will reload entirely with the correct data displayed. Visit the Github repo for update instructions.


1 Like

Just updated with a fix. You can go to the Github repo and follow the update instructions. Note that the old playlist will still not work. You need to clear the old playlist first and add the items back.

If you use Volumio playlists to hold lots of YouTube videos, I suggest you to also read the points under ‘Volumio Playlists’ in the readme to understand the risks of this.

Please report back if possible. Thanks.


@dvo, I’m still on 2.853 and 2.857

run the update please otherwise you get a reboot on trying to play a playlist…
remove old playlists because they would not work any more…
after the update and make new playlists…have fun … and again great work @patrickkfkan :stuck_out_tongue_winking_eye: :stuck_out_tongue_winking_eye:

@ dvo

confiremd on 3.10 running the first version of youtube plugin. when you make a playlist i wound play
sorry for the late reaction going to update now :slight_smile: (CONFIREMD FIX) really sweet NICE :slight_smile: great DAY"S and this is really a nice Christmus Gift :slight_smile:

back online :slight_smile:

morning, here not :slight_smile: 09.29