[PLUGIN] YouTube for Volumio

Is there a way to autoplay related videos? It would be a great option.

youtube plugin is a bit broken… didn’t find any fix for that …

Hi to all,

have installed and configured the youtubw plugin some month ago, then it won’t work with personal api credential. After some experiments and the read of this topic now the plugin is working perfectly. I think the plugin is no more followed by developers but some issues occurs. It’s not a problem. The only great problem is: the music stopped at 80% of the playback. How many users have experienced the same behaviour?
Is there a solution? I’ve noticed that if i launch music subscribed from some channels sometime the track is driven correctly.

Maybe an official youtube plugin with tha chance to use personal api maybe the best. I know it’s not for all, don’t know the solution.

Bye

ps: This announcement is showed on my api page:
"Al momento stiamo riscontrando alcune interruzioni del servizio e non siamo in grado di fornire informazioni sulle quote.

Volumio-youtube-plugin MODIFICA APP

Stato di verifica

Necessita di verifica

Because you’re using one or more sensitive scopes, your app registration requires verification by Google. Prepara la tua app per inviarla per la verifica."

I have to verify the app?

Really great to see that there’s a solution now!!!
However, for me it’s that somehow I fail when it comes to the step where I should grant Volumio read-only access to my YouTube account :frowning: Under “Account Access” there is no code given but stated “Code not yet available. Please come back later.” I came back later 5 min, but still there is no code given. I tried it several times, by switching on and off the plugin, but always face the same problem.
Any idea what I can do?

I like to add: What’s strange to me is that if chose YouTube as source that I can search and find things, it’s only that I cannot play them !?

did you use the youtube-20191224.zip?
did you fill out Api key, Client ID, Client Secret ?
and saved it?
if you don’t get a return key for your device reinstall it again… till you do…
it could be that a firewall could block it… i had that with my firewalla removed it
from my network and worked oke after that…

YT plugin version 0.1.0 ( date 20191224 ) as base.
Also run in terminal : cd /data/plugins/music_service/youtube/
Then run : npm install ytdl-core@latest inside
Then run : reboot volumio

Thx DVO,
I will have a try and report the outcome. Considering that in the past I received the return code I guess it’s not related to a firewall (?).
And yes, I used this zip file.

I’ve tried it several times more (on 2 installations), but it’s always the same :-/

Also I switched off the firewall in the rooter, but also by this I did not get the return code. And I tried “npm” as described.

Should I run “volumio plugin install” as root? In respect to that the plugin is installed I don’t think this makes a difference, but however, should I?

One thing is a bit suspicious: after executing “volumio plugin install” the script doesn’t come back to the prompt. It’s running to the point

Progress: 100

Status :Youtube Playback Successfully Installed, Do you want to enable the plugin now?

Downloading plugin at http://127.0.0.1:3000/plugin-serve/youtube.zip
END DOWNLOAD: http://127.0.0.1:3000/plugin-serve/youtube.zip
Creating install location
Unpacking plugin
Checking for duplicate plugin
Copying plugin to location
Installing necessary utilities
Installing youtube
Finalizing installation
Finalizing installation

But then even after 20 minutes it’s not coming back to the prompt (?)

(you could eazy by pass the router by plugin the one going in to your router most of
the time it’s going in to the yellow rj-45 socket) (most of the time not needed)

(plugin script works oke but hangs on the end. so you get no prompt back.)
the plugin is ready to use just after finalize close the terminal connection then continue.

with this a new terminal connection :
goto in terminal : cd /data/plugins/music_service/youtube/

Then run it from the folder youtube : sudo npm install ytdl-core@latest inside
Then run : reboot volumio

after this go to volumio.local or your ip addres used.
go to installed-plugins switch plugin on … go to settings :
switch off default and put in your credentials… then save
after refreshing the page you should see the return code…
then go to: google.com/device follow the steps…
after that you will see in volumio access granted…
then try a folder to load by me i had some in subscriptions if you see the folders inside…
the plugin works if not try to save your credentials again and try it again till you do see the folders in subscriptions…(if subscriptions is empty pick one you know it’s full )
if your in the folder and see your stuff your in and can use the plugin…

Many thx dvo, I will try this and report about the outcome. I very much appreciate your support!

Btw (needed for sudo), what’s the default root password for Volumio 2?

for sudo you need volumio as sudo password…
in older versions we had root access but that’s not any more…

but with sudo we could do all we need …

Hmm, failed again :frowning_face: means I do not get the return code.

I guess it’s linked with the notification under https://console.cloud.google.com/apis/credentials/consent?project=noble-anvil-289921 - OAuth consent screen - where it is stated under

"Verification status

Needs verification

Because you’re using one or more sensitive scopes, your app registration requires verification by Google. Please prepare your app to submit for verification."

you have to do this by you one i can’t do that for you …must be done with your account
https://support.google.com/accounts/answer/63950?hl=en#

otherwise remove in a few days …and build it again in your account it will work in the end…

hmm, my Google account is verified, so I guess it’s not due to this. The verification I’m asked to is for the app (?)

if you don’t see the code and you did all the steps then it could be the router…
put him in front of the router and restart volumio and hopefully you get a code…
till then try again till you could add it and start if you have it from google.com/device
if it’s still not working i’m out of how to…

I’ve tried it again, switched off the firewall and followed all steps. But I couldn’t bypass my router because it’s a cable router (DSL), so I do not have a rj-45 connector which fits into my rasbi.
However, I guess it’s really linked with that the scope needs to be verified (compare screenshot)
Screenshot_20200923-225837_Samsung Internet|243x500

uhm … if you have a problem connecting you could try a other dns in volumio perhaps?
google’s dns …

adding dns in volumio did not help :frowning:

When you did it or if you check it now, what is stated under “Verification Status” in the “OAuth consent screen”?

i had a firewalla in between works like a firewall but didn’t get my code after i removed it from network
i had a code every time…btw i have now just a new dac and now he runs ok .

Thx dvo,
I’m sure the problem here is not linked to the firewall. It is said that the scope “…/auth/youtube.readonly” is sensitive and requires verification (see screenshots enclosed).