[PLUGIN] Volusonic

Yeah! Great! Thanks a million.

I have de-activated the ID3 button in volusonic, and the duplicates seem to have disappeared! Looks this issue is solved! My naming of album and pathes is generally very good, so, no issue.

Would there be the same kind of tuning to have them disappear also in Volumio alone (without subsonic), like described in my third paragraph? This case is less critical, because the tracks are played in a row, so at least, the album is played once in the right order.

I gave a try to navidrome. Looks nice, but as far as I see, I cannot access to music using the file hierarchy, which is a nogo for me. Access through ID tags only is clearly not enough for me. Thanks for the hint anyway.

Hi Foobarjo,

I have a question about the “random” feature in volusonic. Are these albums extracted from “Music Directory” (ie files hierarchy) or Album list?

As far as “ID3” is now unticked in volusonic, I assume that the Music Directory is used. Could you please confirm?

The question is not trivial, because I use a lot this feature. As far as I know, my “Music Directory” (media_file table) is complete and holds everything, while my “album” table is not.

Thanks for your feedback.

 Denis
1 Like

Hi, Ive got a tricky problem to debug. Hoping someone else has experienced the same. I have never been able to get any airsonic-advanced 11.x build to work correctly with the Volusonic plugin for Volumio. Im running airsonic-advanced on Ubuntu 20.04 and have just done a fresh install and Im now using the internal DB. The files are on a USB drive mounted via ntfs-3g. Volumio is running on RPi3 and is also a fresh install. DSUB/other clients work flawlessly. I have disabled ID3 and persistence.

What happens: After a fresh start of both services, if I start playing an album/playlist and just let it go it will play the next song OK but if I press “Next” the UI will look like its playing the song but the timer wont advance and no sound is heard. If I log into airsonic-advanced with that user, when the main UI is displayed a blank m3u file is downloaded (header record only). The machine running airsonic-advanced will have very high cpu usage. Both services need to be restarted to get anything to play again. I f dont restart but just go back to Volumio after some time I can see that it thinks it is still playing music (ie there is a different song displayed but no sound, song timer not advancing)

In Volumio, I can see the debug entries and the URI loads fine in chrome/firefox. DSUB and all other players perform fine. This was working on airsonic but other bugs forced an upgrade to advanced. It is something between Volusonic and airsonic-advanced but I dont know what to do next. HALP!

Heres some stuff from syslog:

`Dec 12 14:12:45 zoidberg java[544140]: 2021-12-12 14:12:45.566 INFO --- o.a.p.s.CacheConfiguration$CacheLogger : Cache Key: volumio | EventType: REMOVED | Old value: volumio ["JUKEBOX","SETTINGS","STREAM","PODCAST","COMMENT","DOWNLOAD","COVERART","SHARE","UPLOAD"] | New value: null`

`Dec 12 14:12:45 zoidberg java[544140]: 2021-12-12 14:12:45.571 INFO --- o.a.p.s.CacheConfiguration$CacheLogger : Cache Key: /media/home/audio/Music/Angels & Airwaves/[2010] Love. Part One/02 - The Flight of Apollo.mp3 | EventType: CREATED | Old value: null | New value: The Flight of Apollo`

`Dec 12 14:12:45 zoidberg java[544140]: 2021-12-12 14:12:45.574 INFO --- o.a.p.s.LoggingExceptionResolver :` [`192.168.1.44`](https://192.168.1.44/)`: Client unexpectedly closed connection while loading` `http://---.com:5150/rest/stream.view?id=21782&format=raw&v=1.10.2&f=json&c=volusonic&t=``<hidden>&s=<hidden>&u=<hidden> (java.io.IOException: Connection reset by peer)`

`Dec 12 14:12:45 zoidberg java[544140]: 2021-12-12 14:12:45.576 INFO --- o.a.player.filter.RESTFilter :` [`192.168.1.44`](https://192.168.1.44/)`: Client unexpectedly closed connection while loading` `http://---.com:5150/rest/stream.view?id=21782&format=raw&v=1.10.2&f=json&c=volusonic&t=``<hidden>&s=<hidden>&u=<hidden> (java.io.IOException: Connection reset by peer)`

And from Volumio:

`info: CoreStateMachine::syncState stateService stop info: CoreStateMachine::syncState currentStatus stop info: CoreStateMachine::pushState info: CorePlayQueue::getTrack 0 info: CoreCommandRouter::volumioPushState info: No code info: CoreStateMachine::pushState info: CorePlayQueue::getTrack 0 info: CoreCommandRouter::volumioPushState info: ControllerMpd::pushState info: CoreCommandRouter::servicePushState info: CoreStateMachine::pushState info: CorePlayQueue::getTrack 0 info: CoreCommandRouter::volumioPushState info: CorePlayQueue::getTrack 0 info: Received update from a service different from the one supposed to be playing music. Skipping notification.Current volusonic Received mpd info: [1639278765741] ControllerVolusonic::pushState info: CoreCommandRouter::servicePushState info: CoreStateMachine::pushState info: CorePlayQueue::getTrack 0 info: CoreCommandRouter::volumioPushState info: CorePlayQueue::getTrack 0`

More info: I finally managed to get Subsonic (that was previously working with volusonic) installed via docker but to my horror, it no longer works… so this must be an environment (likely) or a volusonic (less likely) issue. The thing is, I have reinstalled both ends of this multiple times. I have even moved my files from the ntfs-3g USB drive to the primary disk to no avail. It just doesnt want to play the next track and Im going insane. Mostly because there is very little help available and debug logs are insufficient to tell me whats going on. Anyone, please, can you tell me where to start with this?

More testing. I have installed airsonic-advanced on Windows with Oracle Java 17. I have added a single new album to the library (local media) and have performed a fresh install of Volumio. The same result. Song fails to play after pressing Next. Is it possible to obtain an older version of the Volusonic plugin? If so, what are the instructions for installing it? Cheers

I confirm that the random list is based on the files and not on the ID3 tags when ID3 is uncheked.

In both case the random is built on the entire library, subsonic build the playlist.

I’m working on the tabs in ID3 mode and will get an update soon.

In some case streams are not played by mpd due to an older version used in volumio.
Could you please test with navidrome or/and volumio 3 as i guess mpd is in a newer version?

Cheers. I am using Volumio 3. I just switched to navidrome (installed on the same Pi as Volumio) and its working!!! Im going to continue to build with my full library with this setup (just need to get ffmpeg installed somehow). Have also tried navidrome on the server that is hosting airsonic and can report that it also works this way. Yay. This has been a bizarre problem and I still really dont have an answer to it, but finally after months I can listen to my headphones again :slight_smile:

Hi.

Thanks for the reply. As I use almost only files, this is perfect for me.

It seems that Subsonic is now a dead product (cf subsonic forum). I’m thinking about switching to Airsonic. Do you have any feedbacks for it? Will Volusonic connect to Airsonic like for Subsonic? Any known issues with Airsonic?

I know you suggested Navidrome, but as it does not give acces to file hierarchy, it’s not complient with the way I navigate in my music.

Denis

Airsonic should work but looks like the development is also on hold or very slow.
There is an airsonic fork: “Airsonic advanced” actively developed but it seems that the streaming library used there does not work with mpd version embedded in volumio (an old one) as cnschulz reported… so… no perfect solution i guess.

I pushed an update in the beta channel that now correctly show all albums by genres.
In case you want to test it you have to :

  • uninstall volusonic v2.0.2
  • activate “Plugins Test Mode” in http[s]://yourvolumiourl/dev
  • install the new version (click on “details” on the plugin card and click on the beta version v2.2.1)

Thanks. I will stay on my “file” structure, which I masterize and maintain. I don’t use ID3 tags at all, so I won’t be a good beta tester for this version… Sorry!

In fact, internally (i.e “at home”), I can go on with subsonic as long as it works OK, because I use it 99% from volumio (it holds all my flac files), and maybe 1% from my laptop. So, I can stay like that.

But I have another instance of subsonic (old version 5.x), which I use for friends and relatives to access my music, and several of them use an Android client for this (same as I when I’m out). Problem: a premium license of subsonic is needed to have this work… Mine is available until August 2022, but I’m not going to buy it again if the product is dead, of course…

Apparently, Airsonic supports the use of Android clients natively, I just installed it and made a few tests (plays flac and mp3 on PC, transcodes flac to mp3 when needed, works with my Android client…). That could be an acceptable solution when my premium license will expire…

Denis

Hi Denis, others…

Well If I am not alone with this problem I have some good news to report! Jellyfin looks awesome. I have only been using for a few hours but it is fast, has support for playlists, an app, a plugin for Volumio(!!) and it also has a metadata engine built in which is a bonus for me. Another bonus is that it sees Volusonic (and many other devices i have) as cast destinations. This means that I can local-cast from the Jellyfin app and pass the output straight to my DAC. So far so good. Its looking like I dont need Navidrome although that does support smart playlists which is enticing :slight_smile: For me, running on Pi, the bulk of airsonic-advanced was just too much. It was super slow and there was so much Java config that it was doing my head in. With the exception of having to compile ffmpeg to install under Volumio, everything else Ive mentioned above has pretty much worked out of the box. Enjoy.

Hi. Thanks, I’ll have a look at Jellyfin, sure. Concerning your performance issues, you could consider moving to RPI4. I have an instance of Subsonic 6.1.6 which runs 24/24 on a simple RPI4-2Gb, and I use Volusonic (thanks to Foobarjo) on a RPI3 to access the music. I must say that it runs flawlessly, it’s fast, responsive, and does what I want. No issue!

Denis

Hi Foobrajo

Have you ever considered integrating the management of “starred” tracks and albums in Volusonic? I see that the subsonic API provides it: getStarred, star, unstar…

Don’t you think it would be an interesting enhancement in Volusonic?

 Denis

This is great. I’ve just set up Volumio and used Volusonic to connect to Navidrome and it all seems to be working just grand.

One minor thing–the tracks I play this way don’t seem to register as being played, and don’t scrobble to Last.fm. Is this due to the way Volusonic works? This seems to work fine on the Sonixd desktop app which uses the same API.

1 Like

Hi Foobarjo,

After years of intensive use of subsonic, I am facing a very strange issue I have never seen before. Maybe you can help me this time again, I know it is not supproted anymore, and airsonic works almost as well. But if you could give me any hint or idea, this would be great.

So, just to recall, I’m using volusonic to connect volumio to my subsonic server (version 6.1.6) on an RPI4 server. This has been working for years now.

The issue I am facing is: I recently discovered that a lot of my albums have their tracks marked “non-present” by subsonic. I can see the album, because the cover file (cover.jpg) is “present”, but I can’t play any of the tracks (0 songs).

The DB is MariaDB. I cleaned everything in the DB and started a new scan.

During the scan, everything seems to be OK: I see that no “non-present” file exists:

MariaDB [subsonic]> SELECT path FROM media_file WHERE present=0;
Empty set (0.001 sec)

But, at the end of scan, I see this in the log:

[6/6/22 8:41:20 PM CEST] INFO MediaScannerService Scanned media library with 142230 entries.
[6/6/22 8:41:20 PM CEST] INFO MediaScannerService Marking non-present files.
[6/6/22 8:42:10 PM CEST] INFO MediaScannerService Marking non-present artists.
[6/6/22 8:42:10 PM CEST] INFO MediaScannerService Marking non-present albums.
[6/6/22 8:42:13 PM CEST] INFO MediaScannerService Completed media library scan.

And suddenly, a lot of tracks appear as “non present”. As you can see, it takes also a full minute ([6/6/22 8:41:20 PM CEST] to [6/6/22 8:42:10 PM CEST]) to Subsonic to mark this files “non-present”.

And I don’t know why. These files are obvioulsy present, they exist in the DB, but the “present” field is set to 0.

It always happens to all flac files of a full album.
jpg files are not impacted

Any help or hint would be appreciated.

Denis

Hi.
The problem comes either from MariaDB, either from the integration between subsonic and MariaDB. Today, I have no idea how to go further this way.
Switching back to the internal DB of subsonic solves the issue.

Denis

such a shame this plugin doesnt work, i never pay for subscriptions but this plugin would of pushed me over had it worked, wasted like 1.5 hours trouble shooting until i figured out it was plugin that doesnt work

Please, your post brings nothing…
You gives no details on what does not work, version for Volumio and plugin.
Where is your log to understand what happens?
Even if it doesn’t work as expected, please consider the free job of the author!
Thanks