[PLUGIN] Touch Display

Looks normal… with the exception that file size of .Xauthority is 0. To not clutter the thread too much with logs, could you PM me the content of /var/log/Xorg.0.log?

I’ve finally fixed my issue by uninstalling and re-installing the TouchDisplay plugin.
A big thanks again to gvolt :wink: :+1:

1 Like

Hi. Hope to be in the right place. I have just connected 7inch Sunfounder display connected through HDMI and USB. Everything fine with the plugin. The only stuff is that when the screen is off (as set in volumio) and becomes black, the backlight anyway is on. Is there any way to get it off? can anyone help? Apologize for the question.
thanks so much for help.
regards

It could be the display does not comply to DPMS (there seem to be several HDMI screens with such an issue, sometimes although the specs claim to be DPMS compatible).

Another reason could be you are using a Pi 4 with older firmware. IIRC the Pi 4 firmware had an issue where “DPMS off” blanked the display but left the backlight on. I think this had been solved not too long ago (half a year or so) but I don’t remember exactly. If you should be using a Pi 4 and want to update its firmware I think this should not be done under Volumio but running Raspbian / Raspberry Pi OS (there has been a thread about this on this forum).

Edit: If not already present in your /boot/config.txt or /boot/userconfig.txt you could try adding the line

hdmi_blanking=1

to one of the files (I recommend to use /boot/userconfig.txt as it survives Volumio updates).

TOP!
tried different screen high quality, issue was there. Then checked the firmwar, it was updated.
now with that string it works perfectly!
thanks so much!
ciao

1 Like

Hello,

I’m sorry if my English is bad and my question is silly.
I have a Sunfounder 7 tacticle with a RPI4 display. I downloaded and installed the Volumio image, then installed the Touchdisplay plugin. My screen is recognized and i have a image but the tactil does not work :frowning: Is there something to do?
Thank you for your reply.

What is the exact model name of the display, please?

How is the display connected to the Pi?

Did you install other software / modify files in order to use the display? If so, please describe in detail what you installed or modified.

Hello,
I bought the model:

  • SunFounder Raspberry Pi 4 7 "HDMI 1024 x 600 capacitive touchscreen
    I only installed the Volumio RPI image and the Touchplay plugins.
    The screen is connected via HDMI.

If it is either this or this display I think you also need to connect the screen and the Pi by USB.

Yes this is the first link. Thank you for this idea I will look at it tomorrow morning. Unfortunately there was no notice on the screen.
Thanks for your time and your reply

Thank you, it works, the screen is recognized and the touchscreen works.
On the other hand, the display is not adapted to the screen. Everything is tiny, is there a solution to make the interface bigger?

According to Sunfounder’s specs add he following entries to /boot/userconfig.txt:

hdmi_group=2
hdmi_mode=87
hdmi_cvt=1024 600 60 3 0 0 0
hdmi_drive=2

Possibly you also have to add

hdmi_blanking=1

if you should encounter the same issue as described above.

Well thank you very much!
It works very well.
Thank you for taking the time to answer me, appreciated

1 Like

This plugin is (mainly) working great for me - on a Pi 3A+ with RPi 7" screen.

One problem, though. I am using this screen to remote control another Volumio instance. When I shutdown the remote instance the twirling circle thing remains on the screen, so I cannot get to the local controls to shut down the screen’s Pi.

Is there a way around this without using a browser on a 3rd device to shut down volumio on all?

Thanks

Is it the same if you do it the other way around, i.e. shutting down the Pi from the other Volumio instance?

Also, do you have the same effect without using the touchscreen but a browser on a third device connected to the Pi to shut down the other Volumio instance?

If I shut the ‘screen’ Pi down first, I can n o longer turn the ‘playing pi’ down since the screen is now off! Again, I have to revert to a 3rd PC with browser.

If I do the same (i.e. navigate to the screen Pi website on a PC) and turn off the playing Pi from there, the same happens! i.e. the screen is taken up by the ‘wait’ twirl.

Can the UI recognise if it is working on a remote Volumio server, and return to the local one if that server is unavailable?

So the issue appears to be not specific to the touch display plugin as it occurs also when using the web interface on a third device.

In the meantime I have set up to Volumio systems (x86) as virtual machines. They show the same behaviour you described. That also argues for the issue not being related to the plugin.

To me it seems there could be a problem with multi room switching between devices. Might be related to the issues reported in the past, e.g.

https://community.volumio.org/t/multi-room-interface-switching/8269
https://community.volumio.org/t/multi-room-problems/8797/16

Maybe bring the issue to attention with a new thread describing the problem with turning off a Volumio system by using the multi room function.

What you could try for the time being is to connect a physical keyboard to your Pi and reload the interface by hitting F5.

Yes, it does seem that way. Not needed to do it before I started with the screen, so thought it was that. Sorry!

I just re-checked with exclusively the Volumio systems running in a VM (i.e. no Pi with touch display plugin in the network - just to rule out any side effect) and it made no difference: The problem you described appeared - hitting F5 on the system with the “blocked” UI makes it usable again.

Thanks. I tried the F5 too on a browser, and it returned to the right screen. However, the touch display does not have that.