[PLUGIN] Touch Display

If you connect a keyboard to the Pi F5 should work on the browser the touchscreen is showing, too.

It should, but I don’t want a keyboard connected.

I see.

Hello,

I try to bring an old POS 12" Touchscreen to work on a RPi3+ with the TouchDisplay Plug-in.
Display is showing everything OK, but I have just a RedHat driver and can’t install it via alien.
So the behavior of the touchscreen is like a mouse, means first tap gives the position, but it needs a second tap to click something. That is not working good, cause you have to hit the exactly same point to click.

Is there a posibility to change the mouse/tap behavior to point&click? So if you tap the screen the mouse knows to position and click at the same time.

What is the brand and model of your touchscreen and how is it connected? What is that RedHat driver? Can it be downloaded somewhere or could you PM me with the driver file?

It is a PointOfSale Monitor for checkout systems.
Wincor/Nixdorf BA82

You can find the drivers here:
https://www.dieboldnixdorf.com/en-us/support/documentation-services/pos-kiosk-systems-peripherals/driver-downloads/displays-graphics
first one in the list

They use an own Linux distro WNLPOS3/4 based on CentOS/RedHat and that is the driver made for.
The touch is connected via USB and is working like a standard-mouse device, the screen is connected via HDMI>DVI and works fine.

So, “DN Universal Touch Driver (UTD) for Linux (Version 2.2.3)” I guess? If so, which of the driver files from the .zip did you use specifically?

Right.
I tried to install the centos65-32, the others are 64bit.

If the installation of the driver succeeded you should have a file “options” in “/etc/opt/wn/wntouch”. Please post the outputs of

cat /etc/opt/wn/wntouch/options

and

ls -al /dev/input/wntouch*

Also check if the files
/opt/wn/wntouch/sbin/wntouch
/opt/wn/wntouch/bin/wnconfig
/opt/wn/wntouch/bin/wnmapping
/etc/opt/wn/wntouch/devices
/etc/X11/xorg.conf.d/99-wntouch.conf
and
/usr/share/hal/fdi/policy/20thirdparty/99-wntouch.fdi
are in place.

Sorry, what I don’t said, I want to install it on a Raspberry PI and the drivers made for i386.
So I cant install it on an ARM.

So my thoughts going to change the click-behavior in the touchdisplay plugin.
Or is there any kind of universal touchdriver?

According to the user manual the touchscreen indeed “registers” as a mouse:

"By default they are recognized as mouse by the kernel and
all events are routed to a /dev/input/mouseX device which is also auto-
matically used by the xorg server. "

That explains the clicking behavior you described. ATM I have no idea how to change that without wntouch binary which seems be available only for x86 devices.

Ok, thanks so far! I just try some hints and see what happens.

Stay healthy

PMed you.

HI all
so sad. I have now a new touchscreen (Magedok t108b, pretty recent, HDMI+typeC) and wrote the following string in userconfig

hdmi_group=2
# hdmi_mode=1 => this as per manufacture but visualization problem
# hdmi_mode=68 => this as per manufacture but visualization problem
hdmi_mode=87
hdmi_cvt=1366 768 60 6 0 0 0

everything fine except the following.
When screensaver time passes, i get the screen off with backlight on.
So I added “hdmi_blanking=1”, and again it worked with reference to the backlight.
The problem is that i get the the “hdmi no signal” but at this time the touch effect (to be used to reactivate the screen) does not work.
Any idea to keep alive the usb signal maybe with alternative string to “blanking=1”?
hope so.
thanks
ciao

Hello,
Could you please tell me how can I install touch display plugin on rpi4 buster version, because I have read that plugins are not yet supported on beta version.
Thanks.

Thanks for that, but I do not know who to instalk it, on other plugins also the steps needed a er e available. With wget… Etc

  1. Download the plugin package
wget https://github.com/volumio/volumio-plugins/raw/gh-pages/plugins/volumio/armhf/miscellanea/touch_display/touch_display.zip
  1. Create a directory for unzipping the plugin package
mkdir touch_display
  1. Unzip the plugin package to the newly created directory
miniunzip touch_display.zip -d touch_display
  1. Change into the directory with the unzipped files
cd touch_display
  1. Install the plugin
volumio plugin install

When the installation process has finished you will see some finalize message (don’t remember the wording in detail) on the command line. You will probably have to hit “Ctrl+c” to return to the prompt.

  1. Optionally delete the downloaded file and the unzipped files:

rm touch_display.zip
rm -r touch_display

  1. Enable the plugin from the UI as usual.

Edit: Corrected file name of the .zip file to download.

Thanks a lot
I really appreciated.

Hello ,

I try to install but it gave me some erro when trying to unzip de zip file .
Could you please help me ,

Thanks err1.txt (4.0 KB)

File downloaded is touch display.zip, not touch_display.zip. Correct your CMD to unzip :wink: