[PLUGIN] Touch Display

Ok, I see…You need to enable pligins test mode. Go to // and click “True” for “Plugins Test Mode”. After that “Details” will show beta versions of plugins, too (3.3.1 is a beta version currently).

Ah! But then I guess the question is why, when NOT in test mode, that 3.3.1 shows up in the listing? Probably just a labelling thing because everything else would make sense. 3.0.1 is the latest stable version. In test mode I see all the betas.

I agree. Probably the plugin store lists the version with the highest number regardless if it’s a beta and if plugins test mode is enabled.

What new features does 3.3.1 bring?

The version does not bring any new features. It only adapts the plugin to meet the requirements of the checklist.

Also plugin type has been changed from “system_hardware” to “user_interface” following the docs.

@gvolt @michel8166
so, Waveshare replied… sorta

serious, suggest your customer to perform some SMD soldering. There goes the warrenty.

1 Like

Oh boy! :grimacing:

Waveshare says that they “haven’t tested the Volumio system on this DSI LCD before”, but the commands exposing the issue are in no way Volumio specific. The commands used to rotate the display and to put the display into DPMS status “off” are standard ones on Raspberry Pis.

It also seems they didn’t test their proposal, so it might well be that replacing the resistor will not help at all…

yeahhhh… that seems super sketch… I responded that I wasn’t about to desolder / reattach a new resistor and if there’s another way to fix it… will keep you updated if they respond again.

New to this thread. I’ve skimmed through it trying to see if anyone else had the same issue I’m having with the Touch Display plugin, and didn’t see it, but might have missed it. If so, my apologies. First, I want to ask if this is possible (and from another old post, I think it should be): I would like to display the Volumio UI on my 55" LCD television through HDMI. No touch screen, so just display. My audio is through digital coax to my receiver, so this is only for UI display. Is this possible?

I am running Volumio 3.173 on a Raspberry PI 3B+. After installing the plugin version 3.3.1, all I see is the Volumio Linux console, and am prompted to log in. Doing so does nothing but leave me sitting at a prompt. What else do I need to do?

I have uninstalled the plugin for now, planning on attempting it fresh. I will say, my previous installation seemed to get interrupted part way through, but then later continued and seemed successful. But I wondered if that interruption might have messed it up.

And this might be nothing, but upon boot-up, I do see the Volumio logo (not the texty one from the ssh screen - although I do get that one eventually - but the legit graphical one). Not sure if that adds anything though.


on boot you will see the volumio logo on screen after boot it goes back to the login screen.

after installing the touch display plugin
did you enable the plugin? you can do this in the plugin section.
under installed plugins there you wil find the touch plugin an it has to be set “on” and then you will see a,
green dot behind it that means the plugin is active.

dvo, yes, I did. I should have mentioned that. It seemed fine from within the Volumio GUI on my phone app.

I tried installing the plug-in again and got the message “Error connecting to the X-Server”. It popped up briefly in the GUI when I attempted to enable the plug-in after this recent install attempt. The message may not be verbatim since it displayed for just a few seconds.

Are you on a fresh Volumio install? If so, did you wait several minutes after the first boot so the data partition could fully expand. On a system where the data partition had not been expended there is typically not enough space for all the software the Touch Display plugin needs.

If you are sure your system is not lacking disk space, I recommend to uninstall the plugin. Then enable “Plugins Test Mode” on //volumio.local/dev and re-install beta version 3.3.2 of the plugin. This new version of the plugin aborts (and rolls back) the plugin’s installation process if downloading/installing of one of the required software packages (xorg, chromium etc.) fails. Unlike before, now the plugin would not even appear in the list of installed plugins if a software download should have failed.

So, if you do not find the plugin in the list of installed plugins after the installation process has finished, it is because an error occurred during its installation. Maybe check your internet connection (especially for DNS problems) and try to install the plugin again.

gvolt, it is a fairly fresh upgrade from Volumio 2.x to 3.x, but I did not attempt to install the plug-in immediately — it was some time later. However my second attempted install seems to be corrupted and my attempt to uninstall failed, so it looks like a fresh reimage is in order. After I do that, I will let things rest for awhile and then try reinstalling the plug-in.

gvolt, I followed your instructions, the plug-in installed without errors, and most importantly it works! It looks great and does exactly what I want. Not sure why the 3.3.1 installation seemed to have problems for me, but all appears good now with 3.3.2. Thank you for your patient assistance!

Most probably a download error… main thing is that it works now. :grinning_face_with_smiling_eyes:

@gvolt @michel8166
and another follow-up from WaveShare
Waveshare Response 02

it seems almost an insult that for a prebuilt screen, I would have to modify it to make it work like it’s suppose to - I’m about to just send this back and find ANOTHER screen for this project (or just trash the entire idea and steal @michel8166’s build idea for a stand-alone component, somehow)…

and to boot, this response came on a “how would you rate the support you received” email, too, so you can guess what kind of rating I’ll be giving them…

I made a fresh install with volumio3 on a Raspberry Pi 3. Then i waited some time and tried to install the plugin. During the install there was an error (sorry i don’t know what exactly). Now the plugin is installed, but does not work and uninstall does also not work. :roll_eyes:
Maybe there is another way to “rescue” the device (purge the plugin), because to reflash i need to disassemble the device again → Not really funny! :stuck_out_tongue_winking_eye:

What is the plugin version?