[PLUGIN] Podcast plugin for Volumio

Volumio 3 Issues?
I cannot find after updating volumio the podcast plugin.
Has this feature been deleted? This would be a realy bad move!

Please see: Volumio 3 issues: hints and solutions before posting a new issue.
(You’ll need to cut and paste the link)

----------------------------- Delete here & above before posting below -----------------

1 Like

I’m a developer of podcast and I update podcast plugin with new feature such as seaching, fast loading episodes and I’ve been contact Volumio team and they will approve the plugin on Volumio 3. But Volumio team usually takes a much time to deliver on their system. So please wait for their action…
Thanks.

2 Likes

Great news! We will wait delighted😃

Podcast plugin 2.0 is released in Volumio 3.0 so you can install it. I added following new features.

  • search podcast directory with keyword
  • add searched result of podcasts
  • set search podcast region
  • set episodes limit of podcast retrieval
  • add podcast favourite function

Thanks.

2 Likes

How can I do. I only see default podcast (samples) not any search menu.:man_shrugging:

Thanks @cgsong! One of the key plugins I’d been waiting for in V3. Works perfectly.

1 Like

@cutandaweb Search and add your podcasts via the Settings tab.
Plugins/Installed Plugins/Podcast/Settings

Thanks your very much.:+1:

Hi @cgsong
Just spotted that after installing the new podcast plugin that my plugin list is now empty. Tried rebooting and clearing cache, but still empty. Screenshot_20220208-101538_Vivaldi Browser|243x500

Tried it on my second system, full list of plugins before installing Podcasts, empty afterwards.

V3.198
RPi 4 v1.4

Hello
I have the same problem as Simone, my plugin list is empty after installing Podcast.
I can’t choose the region. When I click on Select region, the area disappears.
And the podcast search does not work. I enter keywords and click on serch podcast, nothing happens.
V3.198
RPi 4 v1.4
Christian

The updated plugin clears previous saved podcasts and reset with default podcasts…

Podcast plugin searching is based on iTunes podcast region. Some of region have not podcast search directory infomation. If there is no result of searching then please change into USA region and search podcast.

The first problem I have is that I can’t choose the region. The menu disappears when I want to write.

1 Like

It’s not the podcast list that’s missing, it’s the list of plugins. On both my systems, this disappeared immediately after installing the podcast plugin.

I’m working with Volumio 3.198 on RP 4. After installing the podcast plugin, Installed plugins and Search plugins are shown in my system. It is not plugin itself issue so please contact Volumio team for this problem.
Thanks.

I can’t reproduce that you said that. Please capture the screen that you get the problem.
Thanks.

Ok, I uninstalled the Podcast plugin and straightaway the Plugins were all visible again. Then I reinstalled Podcast and this time everything was OK. Perhaps Volumio were working on the plugins menu this morning and I was unlucky. I got exactly the same with my second Volumio.
Anyway, the problem, if there was one is now solved. Thanks for getting back to me and I’ll enjoy the plugin now.
Simon

They did “something” this morning. Both Tidal and Qobuz where vanished like a magical trick. In the source menu was a new button called “streaming”. Which loaded the new plans, on press, Free and a paid plan.
I rebooted and it was gone!

Maybe it’s still going on. Just tested again. 2 systems. Multiple times.

No podcast plugin - plugins menu fine
Install podcast plugin - plugins menu fine
Change country to NL in the podcast settings - plugins menu empty
Uninstall podcast plugin - plugins menu fine

Hello
Here is the screenshot. The menu to choose the region has disappeared.