[PLUGIN] Now Playing

If you’re talking about updating to a version from the beta channel, then no. On the other hand, if you ssh into Volumio, you can do this:

$ cp /data/configuration/user_interface/now_playing/config.json .

(Don't miss the dot at the end)

Then uninstall plugin -> reboot -> install version from beta channel.
Do not enable plugin yet. Instead, SSH back into Volumio:

$ cp config.json /data/configuration/user_interface/now_playing
$ rm config.json

Now enable the plugin.

I was suggesting that you delete the images from your post that show the OpenWeatherMap API Key and Genius Access Token, because they could be used by anyone who sees them. I was not suggesting that you remove it from the plugin settings.

Got it…Thanks…

@ patrickkfkan - Hello, Thanks again for your work on this plugin.

I’m have a little query - I use RPi4 with latest build of volumio and your latest beta (0.3.6) along with peppy meter - My scenario is I use the volumio app on my android phone to select which music I want to play, everything works well and an album will play - what I noticed today was when the album finished my screen did not default to the idle screen with weather and time information, I left it for many minutes but stayed on peppy meter screen - only when i touched the screen (using 10.1 touch screen) the peppy meter was gone and the weather info popped straight up, it was almost like the weather info was already loaded but wouldn’t show until I touched the screen…Would you happen to know what can cause this?

Thanks

Correct me if I’m wrong since I don’t use peppymeter, but I think it is a screensaver that kicks in when there’s no user activity like touching the screen. Is there an option to turn it off when nothing is being played?

I don’t think so - these are the settings I can see…Thanks

Not sure then. Perhaps others can answer…

Ok, thanks.

Please check your settings in touch display plugin, screensaver time out. I have set mine to 360 sec and it works very well.
Regards C

Love, love, love this plugin. I don’t get the weather icons, but it does show the data. Am I missing a font, perhaps?

No, the weather icons are SVG images. Have you tried viewing the page in a desktop browser (go to http://your volumio address:4004?

Thank you very much for these instructions. Really helpful!

https://imgur.com/gallery/xvNtlE8

Weird, sometimes not even getting the text. (screenshot)

What browser are you using?

Reboot Volumio and then refresh the browser. See if that helps.

Ah, I do recall something about Firefox and SVG images. Here’s a shot in a chrome tab.
I get same result on the display I have hooked directly to the Pi.

This IS NOT a big deal, so if it’s something with my config, don’t worry too much about it. People tend to expect the world from a dev’s time sometimes. I just appreciate this exists at all.

Chrome tab after a reboot

Hi, I changed the setting as you mentioned but after the album ends my display stays on the peppy meter screen and does not go back to idle weather screen.

What version of touch display are you running?

Thanks for the help.

I’m curious as to why the icons aren’t showing. I thought it might have something to do with missing mappings between weather condition codes and image paths, but just tested with your location and they appear fine on my end.

If you don’t mind, could you hit F12 in your browser to bring up DevTools? Then click the Inspector icon in the top-left corner of the DevTools panel and point to one of the forecast blocks, like this (screenshot is Firefox):

I have clicked on “SUN” and I see this in DevTools:

image

The highlighted line points to the “SUN” text element. Now just a bit further down is the SVG image element:

<img class="IdleScreenWeather_Forecast__icon__DYq8O" src="http://192.168.11.5:4004/assets/weather-icons/fill/svg-static/partly-cloudy-day-rain.svg" alt="">

Do you see this element, and is the src URL there? If you do see the src URL, could you try opening it in a new browser tab (you can double-click on the src URL and copy it to clipboard)? What do you see?

When this happens, could you go to http://<your volumio address>/dev and check what the status is under “Player State”? Just want to make sure that the status is correctly reported.

So… Get this. I hooked up a different display just for the heck of it (1080p) and they showed up on the directly connected screen. Both on the main screen playing (top icons) and in “screensaver mode”. The original display was an 8" 1280x720. Using the same HDMI connection for both.

Perhaps it was having trouble with the resolution? In the browser I’m just seeing the wallpaper, but on the attached screen it seems to be behaving properly.

and attached directly :

1 Like