Pi Zero W Installation stalls

I want to use this excellent software on a RPi Zero W as I am putting one inside a shower radio and it will be powered by a hydro generator from the shower itself. I can get the software to load and work with my RPi3B+ but the installation from a fresh image stalls. ( Image is 2.598 )

I have tried installing with fresh image ith a ether-usb fob connected to my network and I have tried with a fresh image without the ether connection. In all cases the installation stalls. ( works perfectly if I use a fresh image on my RPi3B+ )

I am thinking the firmware on the Pi Zero W was changed, I have previously run “Buster” on it and “Stretch” – both with working wifi.

3 images show, 1. First Boot, 2. a reboot, 3. the partitions left after the first boot.

Volumio SD card after First Boot.png

Found legacy image from 2-18-2019 put that in and it all worked.

We located a build issue with the newer images for the older PI versions.
Some of us are still on holidays so please give us a week or so to sort this out.

Thanks, it is an AWESOME program!

Well that didn’t take long!!!

2.599 loads perfectly and is beautiful!